Upgraded? Custom Fields now missing? This might help.... - Bugs & Issues - Bugs & Issues - Progress Community

Upgraded? Custom Fields now missing? This might help....

 Bugs & Issues

Upgraded? Custom Fields now missing? This might help....

  • Upgraded? Custom Fields now missing? This might help....
  • Hi all,
    Just wanted to share something that I found when upgrading from 5.3 to 6.0 the other day. After the upgrade our files and documents were missing a custom field that we had added.
    To start with it looked like it was an error with the librariesConfig file and that it would need to be fixed in the next update by Sitefinity - this may still be the case but I found a solution which fixed the problem without waiting for the update.

    Go to the Files and Documents screen, on the right hand side click Custom Fields and you will see all your custom fields still within Sitefinity but obviously they aren't showing on the backend pages.

    Click on the custom field that you are missing, this will bring up the settings screen for that field. Make sure the appearance setting is :
    "All screens where you work with documents or other files in the Backend" then click Done.
    Followed by 'Save changes'.

    This then resaves the custom field and as if my magic, the custom field now displays on the backend again.

    Hope this is helpful. We had a slight panic that we had lost the custom field and it would be a long wait for the next update!!
  • Hi Owain,

    Thank you for sharing the solution of this problem with the community. I hope that the information will be useful if someone encounters the same problem.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Thank you Owain. I ran into the same issue, affecting my Blog custom field. Your solution fixed it.

    Jeremy