RegisterRequiresControlState can only be called before and during PreRender. - Bugs & Issues - Bugs & Issues - Progress Community

RegisterRequiresControlState can only be called before and during PreRender.

 Bugs & Issues

RegisterRequiresControlState can only be called before and during PreRender.

  • RegisterRequiresControlState can only be called before and during PreRender.
  • Hi,

    I am still new with Sitefinity and still exploring, i am using sitefinity 5.1

    I get this error while i try to edit one of my pages

    RegisterRequiresControlState can only be called before and during PreRender.

    i also posted some Print Screen below

    But i still can preview, edit title properties, and edit permission

    Any idea why this is occurring ?

  • Hello ***,

    We need more information about your environment:
    1. Do you have a custom widget, that inherits Sitefinity document list widget?
    2. Do you have more than one Sitefinity document list widgets in your page, this can cause the problem indeed?
    3. Have you tried to modify somehow the documents collection?

    We need exact steps to reproduce the problem.

    Regards,
    Slaveya
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  • I too am having this issue but in version 6.3.5000.  It also occurs when I'm trying to edit a page and while I have no custom widgets, I do have multiple document lists on the page.  What do I do to get around this obvious bug?

  • Hi Judy,

    The issue you are experiencing may come from the fact that the control you have placed on the page cannot find its appropriate placeholder in the layout control it is dropped in. This causes the widgets in this layout control (in your case this might be the Download list) to be rebinded which would call the DataBind 2 times and receive the exception.

    What I can suggest is to go to the page template and remove the layout control where the widget is placed in and then also remove the widget and then add them again. This way the widget will inherit its placeholder and this should resolve the issue.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items