Kendo aspnetmvc wrappers not compatible with page editor's requirejs? - Bugs & Issues - Bugs & Issues - Progress Community

Kendo aspnetmvc wrappers not compatible with page editor's requirejs?

 Bugs & Issues

Kendo aspnetmvc wrappers not compatible with page editor's requirejs?

  • Kendo aspnetmvc wrappers not compatible with page editor's requirejs?
  • I'm using  bringing in jQuery and KendoWeb into the master page using
     <sf:ResourceFile JavaScriptLibrary="JQuery" /> and <sf:ResourceFile JavaScriptLibrary="KendoWeb" />.

    These are working perfectly between both in both page-editing and non-page-editing mode.

    However, as soon as a I attempt to bring in kendo.aspnetmvc.min.js using the cdn, the page editor's RequireJS dies with"Mismatched anonymous define() module."

    What's the recommended way to bring kendo.aspnetmvc.min.js into a sitefinity site that maintains functionality in and out of page editor?

     


     

  • Hello Aaron,

    I believe we have answered your question in the support ticket.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  • Sabrie, what is the solution to this?
  • The solution proposed from support was to download a copy  of kendo.aspnetmvc.min.js locally and alter the file, removing the attempt to register itself with require.js. 

  • To anyone looking to solve this -  I don't know if this was the best way around the problem but when I download the kendo.aspnetmvc.min.js file as a custom download from here:

    www.telerik.com/.../custom-download

     I.e. Tick the box only;

    And include that in Sitefinity as kendo.custom-aspnetmvc.min.js it worked without a hitch.