Redirect from a library path not working - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Redirect from a library path not working

  • Redirect from a library path not working
  • Hello,

    We recently launched a new site for our customer, and as part of this are trying to redirect links to documents to their new path. 

    The old path looks like 'lib-docs/default-source/general-documents/document.pdf'

    The new path is 'docs/default-source/general-documents/document.pdf'

    So we created a redirect page accepting the first url and redirecting to the second, but we persistently get a 404 error when accessing the old URL.  Any advice on how to handle this within Sitefinity?

  • Hello Scott,

    This issue is caused by a bug in Sitefinity as described in the below KB articel:

    http://www.sitefinity.com/developer-network/knowledge-base/details/additional-urls-with-extensions-for-images-and-documents-do-not-redirect-to-the-default-one

    I am sorry for the inconvenience caused by this issue. As a workaround please use rewrite rules in your web.config file or redirect your users to the default document url in the Application Begin Request method in the Global.asax file.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items