Image Upload failing on all browsers using Sitefinity 7.x and 8.x - Bugs & Issues - Bugs & Issues - Progress Community

Image Upload failing on all browsers using Sitefinity 7.x and 8.x

 Bugs & Issues

Image Upload failing on all browsers using Sitefinity 7.x and 8.x

  • Image Upload failing on all browsers using Sitefinity 7.x and 8.x
  • Hi all - 

    I'm experiencing an issue with Kendo UI and it's KendoUpload jquery plugin that seems to be server specific. I have multiple instances of Sitefinity throwing the same error, but I can't seem to determine what the root cause of the error is. On the kendo upload success callback, I get an error that the response is undefined. Sure enough, as I track down the caller of this function - I get an empty array of files and it seems like this code is losing track of the file upload. Is there a configuration I have to make somewhere that would address the issue? Oddly, this is working on my local development machine, so the question is if it's possible I have a permissions issue or not?

    Here's the code snippet - the error I get back after the file uploads is that e.response is undefined:

    function _kendoUploadSuccess(e) if (!e.response[0].UploadResult) alert(e.response[0].ErrorMessage); if (that._usedByMediaContentUploader) that._fileRemovedHandler();

     

    Just a side note. We've also tried saving to the database and to the file system. Both are returning the same error.

     

    Thanks!

  • We've also tried saving to the database as well as the file system. Both are returning the same issues.