Trouble With OpenID Authentication in Sitefinity 10 - Bugs & Issues - Bugs & Issues - Progress Community

Trouble With OpenID Authentication in Sitefinity 10

 Bugs & Issues

Trouble With OpenID Authentication in Sitefinity 10

  • Trouble With OpenID Authentication in Sitefinity 10
  • 0512561e-37c1-6deb-a958-ff0000446526_openid.png

    I have downloaded and installed a brand new copy of Sitefinity 10 and am trying to test the new Social Authentication feature. I followed the instructions here (docs.sitefinity.com/administration-social-media) to  configure my site to use Facebook Authentication. When I attempt to register an account using the Facebook option it prompts me to enter my credentials on the Facebook site. Once I log into Facebook, it returns to my site (sitefinitytest.com/sitefinity/authenticate/openid/callback?error=access_denied), but I get a popup in Windows asking me to authenticate and is preventing me from completing the registration with Facebook.

    I get the same result with other OpenId providers as well. I have also tried this on a few different Sitefinity 10 installations and always get the same result. 

    Any help would be appreciated.

    Thanks

     

  • We have the exact same issue - we just tried this on a new sitefinity 10 project
  • Ah, same here, has anyone actually got the new auth to work yet?

    I can step through the code and see that i'm getting everything back from my STS okay but Sitefinity errors

     

    http://www.sitefinity.com/developer-network/forums/developing-with-sitefinity-/sitefinity-10-with-custom-openid-auth-provider