Upgrade from 8.x to 10.0.6421.0 - Backend pages - Error parsing template - Bugs & Issues - Bugs & Issues - Progress Community

Upgrade from 8.x to 10.0.6421.0 - Backend pages - Error parsing template

 Bugs & Issues

Upgrade from 8.x to 10.0.6421.0 - Backend pages - Error parsing template

  • Upgrade from 8.x to 10.0.6421.0 - Backend pages - Error parsing template
  • Hi, after upgrading sitefinity, and after alot of work to get it to work, I got it to render all pages correcly on the frontend, but when loggin in to the backend only the dashboard was displaying any data.

    If I try to go to "Pages" its completely blank, no error displayed.

    If I inspect the html I can se that theres is an error saying :

    <div id="ctl04_frontendPagesListView" style="display:none;">
        <span>Error parsing the template</span>
    </div>

     

    Is there any way I can debug this to try and findout whats wrong?

    Im sure theres alot of changes between version 8x and 10 so its surely something that has gone wrong there...but what?

  • I also have come across this issue. I recently did an upgrade from 6.2 to latest and all the content pages (like "~/Sitefinity/Pages") are showing up blank and have the same error message hidden in html as described by OP. What is causing this issue and how can we fix it?
  • I put a ticket in and got a fix for this: knowledgebase.progress.com/.../Pages-and-Content-sections-not-accessible-after-upgrade-to-8-x.

    Apparently there is a .dll in the _EmptyProject/bin folder that needs to be added to the upgraded project. The HtmlSanitizationLibrary is what sanitizes the html from the templates so it can be rendered properly.