HTTP POST TRIGGER - Forum - Rollbase - Progress Community

HTTP POST TRIGGER

 Forum

HTTP POST TRIGGER

This question is not answered

Hi All,
I have a problem sending a JSON body using HTTP Post Trigger. I'm having a

System Error: Connection Reset

even just debugging the trigger.

I am sending a 70KB jpeg image which I am converting into a binary string inside the JSON

{
"device":"rollbase"
"message":{
"type": "participantinfo",
"full_name": "Some Name",
"rfid_tag": "RF1231444",
"attendance_id":123455,
"meeting_ids": "4522",
"id_photo": "binary string"
}
}

All Replies
  • What happens if you send the same content to the web service end point using (i.e.) Postman?

  • I tried sending it through Postman and it did pushed through.

  • Is it a public end point that I could reach as well?

    Are you using private or public cloud version of Rollbase?
    If private, what version of Rollbase are you using?

    What did you define as Trigger Properties? :

  • Hi,

    The end point is barhead.reekoh.com:8051/.../data

    We are in a private instance using Rollbase version 4.4.1.0

    Trigger Properties:

    Content-Type: application/json

    Authorization: Basic [key]

    I already set the Timeout to 50000

    We noticed that it can push through using small sized binary string.

  • Anything useful in the logs? (i.e. catalina.<date>.log)

  • Negative. There are no entries in the logs related to that error.

  • Hi Van,

    Can you try sendjsonrequest API using object script trigger and see the response?

    documentation.progress.com/.../

    Regards,

    Shiva