Generate XML File Error - Forum - Rollbase - Progress Community

Generate XML File Error

 Forum

Generate XML File Error

This question is not answered

Hi all,

I've been generating XML files to export > import my applications onto a new server but I've come across an error on the "Generate XML" page.

I've made some changes to the applications application and my error lies with exporting this app.

It seems that I have some reports, under pages > reports, that show the error of "not found". these reports exist in other objects that don't have any relationships to this applications app. Why would these reports even show up under this apps generate XML process for this app?

Regards,

Simon Tregloan-Reed

All Replies
  • Can you check the page that shows the error and see if the reports are added to it?

  • Hi Manooj,

    It's the default Rollbase application and the errors relate to reports that are located in other apps, not this default application. I hope this helps.

    Regards,

    Simon Tregloan-Reed

  • The error we are getting:

    Any suggestions?

    Cheers.

    Iram

  • You are exporting Rollbase application with its Reports tab. This tab is the default location for report links to be added for newly generated reports across all applications. Please remove the links to reports of objects that are not part of this application.

    This is similar to having a list view for an object that is not part of this application. It does not make sense if the target system will not have the entity.

    You could however add all objects pertaining to reports as dependent objects (meaning they are provided for in the target system), which will allow you to generate the app XML with the report links.

  • Hello Santosh,

    Thanks for your reply. I figured that would be the case, however, I did already include those objects with reports as dependent objects in the first place and I am getting this error after I have made that change.

    Iram

  • Hello Iram,

    Can you check if you see the same issue on the ESAP instance? I did not find these errors in my 4.4 installation.

  • Hello Iram,

    Also, if it is still an issue, can we work together on this through a Support case - we can then share screens / request your application with the artifacts and move faster on it.

    Regards,
    Karthikeyan
  • Hello ,

    Created a support case for this: 00393616.

    Cheers.

    Iram