Using Outlook 365 - Forum - Rollbase - Progress Community

Using Outlook 365

 Forum

Using Outlook 365

  • Has anyone used Outlook 365 exchange email settings and succeeded for Rollbase. Here's my setting;

    MailHost=smtp.outlook365.com

    MailPort=587

    MailUseSSL-true

    This doesn't seem to be working

  • Hello,

    The MailHost "smtp.outlook365.com" seems to be invalid.

    You can confirm that by using "telnet smtp.outlook365.com 587". This command would return a connection failed message.

    Also, if you visit the web site, you would see that the domain is for sale.

    The following article at Microsoft web site points to the MailHost  smtp.office365.com:

       technet.microsoft.com/.../dn554323.aspx

    If you try "telnet  smtp.office365.com 587" you will see that it responds showing that an SMTP server is running at that port.

    If you visit the web site, it redirects to a Microsoft web site. (The certificate seems to be from Microsoft but it does not include an owner.)

    I hope this helps.

  • My apologies egarcia, and thank yyou for the response.

    The server I used was smtp.office365.com. outlook365 was a typo.

    so here are my settings;

    MailHost=smtp.office365.com

    MailPort=587

    MailUseSSL=true

    This doesn't seem to be working. Here's the error message:

    javax.mail.MessagingException: Could not connect to SMTP host: smtp.office365.com, port: 587; nested exception is: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

  • Hi Hosny,

    I found a forum thread which explains the correct settings for Office 365. The cause for this Exception is Office 365 is allowing connection only through Secure SMTP(smtps) & TLS. 

    For more information, please check this thread: http://community.office365.com/en-us/f/148/t/189832.aspx

    Regards,
    Godfrey

  • Hi Godfrey, Thanks for the reply. I searched the forums and couldn't find anything. Can you point me to the post please?

  • Looks like Office365 uses the smtps (secure smtp) protocol. In javax.mail  this property has to be set as

    mail.transport.protocol="smtps". Does anyone know how to configure this in PAS?

  • Include changes related to mail protocol in the appserver.properties and try out.
    i.e. …. Pas_Instance\conf\appserver.properties
    restart the PAS instance to effect the changes.
    I haven’t tried at my end.
     
    Hope it helps.
     
    Regards,
    Ganesh
     
    From: HosnyA [mailto:bounce-HosnyA@community.progress.com]
    Sent: Wednesday, November 26, 2014 4:02 AM
    To: TU.Rollbase@community.progress.com
    Subject: RE: [Technical Users - Rollbase] Using Outlook 365
     
    Reply by HosnyA

    Looks like Office365 uses the smtps (secure smtp) protocol. In javax.mail  this property has to be set as

    mail.transport.protocol="smtps". Does anyone know how to configure this in PAS?

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • I tried few things like adding mail.transport.protocol=smtps, mail.transport.protocol="smtps" and props.put(“mail.transport.protocol”, “smtps”). None of them worked unfortunately. Have I done it right?

  • Not sure, If it a JVM property then it will get added.
     
    Mike Jacobs can help you on this, I guess.
     
    From: HosnyA [mailto:bounce-HosnyA@community.progress.com]
    Sent: Wednesday, November 26, 2014 3:47 PM
    To: TU.Rollbase@community.progress.com
    Subject: RE: [Technical Users - Rollbase] Using Outlook 365
     
    Reply by HosnyA

    I tried few things like adding mail.transport.protocol=smtps, mail.transport.protocol="smtps" and props.put(“mail.transport.protocol”, “smtps”). None of them worked unfortunately. Have I done it right?

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hosny,

    I have updated my response. For some reason, my response got trimmed when it got posted in the forums.

    Godfrey
  • There appears to be no way to configure TLS and other properties required by Office 365 in the shared.properties file. I have filed defect PSC00322185 to track this issue.

    Godfrey
  • I have also an issue with this part. Our mailserver could only accept TLS, but there is no way to configure that..

  • Hi Hosny,

    You can now set the encryption to TLS on the latest version (3.2) of Rollase Private Cloud. This will allow you to integrate with Office 365. Simply set the value of MailUseSSL to 2 in shared.properties and restart you server.


    Regards,
    Godfrey
  • Thank you for the information Godfrey, we have installed 3.2 now and it's working well with Office 365.

  • Just want to point out you can also set up *per tenant* Mail Server on public as well as private cloud (use 3.2.1).
     
    Administration Setup > Email Server Settings.
     
     
     
     
    From: HosnyA [mailto:bounce-HosnyA@community.progress.com]
    Sent: Thursday, April 09, 2015 6:44 AM
    To: TU.Rollbase@community.progress.com
    Subject: RE: [Technical Users - Rollbase] Using Outlook 365
     
    Reply by HosnyA

    Thank you for the information Godfrey, we have installed 3.2 now and it's working well with Office 365.

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.