Adding a merge field to a web url - Forum - Rollbase - Progress Community

Adding a merge field to a web url

 Forum

Adding a merge field to a web url

This question is answered

I'm trying to add a field from my current user to a URL on a Web tab in Rollbase.  However, when I use the template helper, it is not passing through the values from my field.  See below for the URL that I am using, which includes the template helper.  I've also included a screen shot of the field on my user and what shows up in the URL.

Any help would be appreciated.

Verified Answer
  • Hi Jason,

    I was not able to reproduce the issue on my instance. Can you provide more information on this?

    1. What is the field type of Subordinate Sales Agents?
    2. Are the other tokens (e.g. {!#CURR_USER.firstName#value}, {!#CURR_USER.Rtask}) working on the link URL?
    3. If you change the link URL to 'http://www.bing.com/search?q={!#CURR_USER.subordinate_sales_agents#value}', what is the result?


    Thanks,
    Godfrey
All Replies
  • Hi Jason,

    I was not able to reproduce the issue on my instance. Can you provide more information on this?

    1. What is the field type of Subordinate Sales Agents?
    2. Are the other tokens (e.g. {!#CURR_USER.firstName#value}, {!#CURR_USER.Rtask}) working on the link URL?
    3. If you change the link URL to 'http://www.bing.com/search?q={!#CURR_USER.subordinate_sales_agents#value}', what is the result?


    Thanks,
    Godfrey
  • I'm also curious why your browser's address bar contains the result of the link URL. The address bar should still contain Rollbase URLs as it holds the main page.
  • Hi Godfrey, I don't know what I had going on yesterday when I posted this.  It appears to be passing the values through now without any issues.  As for your question on why it was in the browser, I was using the preview link option within the edit section of the URL.  When in the tab, it displays the Rollbase url.