RB Required Radio Button field in version 2.2+ - Forum - Rollbase - Progress Community

RB Required Radio Button field in version 2.2+

 Forum

RB Required Radio Button field in version 2.2+

This question is not answered

Hi,

How can you make the required radio button field visible in red on the actual page?

Thank you in advance.

Ryan

All Replies
  • Presently this is not available in Rollbase.

  • Hi Ryan,

    You can use the code below as a workaround solution to your problem. 

    <script>
    function toRequired(integName) {
      $('#rbi_F_'+integName).find("input").before("<div style='border-left: 3px solid #990000; width: 3px; height: 20px; float: left;'></div>");
    }

    $(function() { 
      toRequired('myradio');
    });
    </script>

    **Change the text in yellow to the integration name of your radio button field.

    Regards,

    Godfrey

  • Thank you Godfrey. Workaround is the way to go for this version, but as much as possible we don't like to go with it because we don't want to have a very repetitive work when we upgrade later on.

    Ryan

  • FYI: you can always submit this as an idea if you want to see the radio button field visible in red. Other users can see your idea(s) and vote on ones that appeal to them. Check this link for detailed information: knowledgebase.progress.com/.../P11255 .

    Kind regards,

    Hans