Email from Rollbase use UTF-8 charset. How can I change this? - Forum - Rollbase - Progress Community

Email from Rollbase use UTF-8 charset. How can I change this?

 Forum

Email from Rollbase use UTF-8 charset. How can I change this?

This question is not answered

I use an email-trigger to send an email from a template.

This email is sent with UTF-8 charset.

My norwegian characters will then be a "mess".

Ex. "�ran �st" instead of "Øran øst"

How can I change this?

All Replies
  • Please check "Email Encoding" setting on "My Settings" or "Edit User" page.

  • The user is set up with  "ISO-8859-1" encoding....

  • Have you also tried changing the Email Encoding from account settings? You may check it via Settings -> Administration Setup -> Account Settings.
  • ISO-8859-1

  • May I know what Email Client are you using? I tried to reproduce the issue on the public cloud but the results are the same regardless of the email encoding setting.

    It would also be nice if you can upload an application XML which contains the email template and trigger so I can personally test it.


    Thank you very much,
    Godfrey

  • Outlook 2013.

    When I try this today everythingis ok.

    I have no idea of what the problem was.

    The case can be closed.

  • NO, it is not OK!!!

    If I use the "Send"-function everything is ok.

    If I use a trigger "Send E-mail" then the norwegian characters is wrong.

  • Both 'Send' (From More Actions) and 'Send E-mail' trigger worked in my environment. Did you use the same template in your test?

    Also, the Norwegian characters should be substituted into HTML entities when composing the Email Template. For example, the email template will show 'ØØØøøø' but the HTML source contains the following:

    <p><span>&Oslash;&Oslash;&Oslash;&oslash;&oslash;&oslash;</span></p>

    Can you please confirm if your template(s) were also substituted with the correct HTML entities?

  • My Template:

    -----------------

    Test start.

    æøå

    ÆØÅ

    Test end.

    HTML:

    ---------

    <p>Test start.</p>

    <p>æøå</p>

    <p>ÆØÅ</p>

    <p>Test end.</p>

    NB! Progress has reproduced this error and registered a PCS.

    Or....