The current Oracle Wire protocol driver does not support  SQLNET.ALLOWED_LOGON_VERSION=12.  Please consider adding support in an upcoming patch.

http://docs.oracle.com/cd/B28359_01/network.111/b28317/sqlnet.htm#NETRF196