PROTERMCAP error - Forum - OpenEdge RDBMS - Progress Community
 Forum

PROTERMCAP error

This question is not answered

Hello Team,

I am  receiving this alert.. Please suggest the root cause. 

** Could not find terminal type dumb in file . (146)

Unable to use your terminal. Check your PROTERMCAP file. (443)

Thanks!

All Replies
  • You need to set your TERM setting.  Typical setting are vt100 or xterm

    # TERM=xterm
    # export TERM

    Mike
    -- 
    Mike Furgal
    Director – Database and Pro2 Services
    PROGRESS Bravepoint
    617-803-2870 


  • Thank you mike,

    where i need to do the changes..

    alerts are coming from Prod Database Environment.

    Thanks!  

  • Put the changes in your .profile file.  You need to be able to login and get to a UNIX prompt to do this.  You may need to set your TERM=xterm before you can edit this file.  You will also need to know ‘vi’ to edit this file.  

    Mike
    -- 
    Mike Furgal
    Director – Database and Pro2 Services
    PROGRESS Bravepoint
    617-803-2870 


  • If this is in Production, then I presume it must have been working ok previously. So what has changed? What are you actually trying to do? Have you done it successfully before?
    Mike’s advice is correct in that this is how you might start solving the issue, but your revelation that this is production makes me a little nervous for you!
  • TERM="dumb" used to set for the background processes like cron. If it's the case then TERM can be changed in a script that starts a job.

  • James we have "promtfix" script that will update prompt related setting.

    TERM=vt100

    export TERM

    Now alert has been removed.

    Thanks a lot every one.