Autostart databases don't start - Forum - OpenEdge RDBMS - Progress Community

Autostart databases don't start

 Forum

Autostart databases don't start

This question is not answered

OE 10.2B08 on Windows. 

Customer's databases are set to autostart, but get the following in the Admin Server log file when they try to start on reboot: 

[20/02/17 08:50:19] [2] [Database]              Config l_idx_idx.defaultconfiguration - Message from l_idx_idx.defaultconfiguration.defaultservergroup (primary): [08:50:19 BROKER  0: Unable to find server l_idx_idx with protocol TCP in file SERVICES or SERVICES file not found in expected location. (5192)] (ADMMsg057)
[20/02/17 08:50:19] [2] [Database]              Config l_idx_plink.defaultconfiguration - Message from l_idx_plink.defaultconfiguration.defaultservergroup (primary): [08:50:19 BROKER  0: Unable to find server l_idx_plink with protocol TCP in file SERVICES or SERVICES file not found in expected location. (5192)] (ADMMsg057)
[20/02/17 08:50:19] [2] [Database]              Config l_idx_pctrl.defaultconfiguration - Message from l_idx_pctrl.defaultconfiguration.defaultservergroup (primary): [08:50:19 BROKER  0: Unable to find server l_idx_pctrl with protocol TCP in file SERVICES or SERVICES file not found in expected location. (5192)] (ADMMsg057)

When I try to start them manually they work fine. And the services entries are there. 

Any ideas? 

All Replies
  • maybe something to do with user rights ?

    has the user of the adminservice enough rights ?

  • The admin service is set to use the local system account to log on. The thing that makes me a little wary of this as a cause is that I can start the databases fine from the localhost:9090 web front end after the server has booted.

  • Does setting the service to 'Automatic (Delayed Start)' help?

  • Yep, I'd suggest that. Maybe some network service has yet not started by the time the database is starting up.

  • Thanks for the suggestion. I'll try it. Can't confirm it's working or not until they have to reboot again, but at least we're trying something.

  • They had an unexpected server reboot last night and setting the Admin Service to delayed start has not solved the problem. It's only hitting one database now though, rather than 4: 

    [12/03/17 22:18:01] [2] [Database]              Config l_idx_pslrpt.defaultconfiguration - Message from l_idx_pslrpt.defaultconfiguration.defaultservergroup (primary): [22:18:01 BROKER  0: Unable to find server l_idx_pslrpt with protocol TCP in file SERVICES or SERVICES file not found in expected location. (5192)] (ADMMsg057)
  • does the services file have an empty line at the end of it ?  Seems like there is something about the formatting at the end of the services file.

  • Fix the windows services file to contain "l-idx..." as it says in the message....or change to using port numbers instead of port names.

  • There's an empty line at the end, and the services file contains the valid databases. dbman -all -start starts the databases fine after the server has fully booted.

    I've gone back to the client and told them it's something they need to sort with their server vendors, but it would be nice to be able to go back with a possible solution.