Encrypt Password (genpassword) - Forum - OpenEdge RDBMS - Progress Community

Encrypt Password (genpassword)

 Forum

Encrypt Password (genpassword)

This question is not answered

Has anyone tried genpassword utility? 

I've created a "temp" user with password "temp" in database and i am trying to connect with below command.

$>genpassword -password temp

$>24372237

$>pro -db <dbname> -U temp -P oech1::24372237

i even tried with quotation mark.

$>pro -db <dbname> -U temp -P "oech1::24372237"

It's giving error "** Your Password and UserId temp do not match. (710)"

All Replies
  • The genpassword works perfectly. It is giving you an error because you are trying to give the encrypted password but the system accepts it as the plain text. So if you use genpassword for temp  then while accessing the user using username and password you need to give the actual password but not the encrypted one.

    Syntax:

    pro -db <dbman> -U <uname> -P <password in plain text>

    try this:

    $>pro -db <dbname> -U temp -P "oech1::temp"

                           or

    $>pro -db <dbname> -U temp -P temp

  • It's not working. I am trying on OE10.2B, OE10.1C and 10.B

  • thanks sai.

    Just read one ProKb. I am trying in wrong environment. It'll only work with OpenEdge11.x not on progress9.x and openedge10.x

  • Oh no worries, I also haven't checked the version. I will try to answer the upcoming questions with more care.