Is there a relation between -Mm and semaphores ? - Forum - OpenEdge RDBMS - Progress Community

Is there a relation between -Mm and semaphores ?

 Forum

Is there a relation between -Mm and semaphores ?

This question is answered

AFAIK the answer is no but I want to double check.

Today I changed -Mm from it's default 1024 to 20480, (see https://community.progress.com/community_groups/openedge_rdbms/f/18/t/26016).

Now they are getting semaphore errors, I think it's unrelated but I want to be sure.

Second question

Is there an increase in the number of sempahores used by OpenEdge 11.6 compared to OpenEdge 10.2B on linux ?

[2016/07/14@00:26:16.996+0200] P-17010      T-140595944453952 I ABL    87: (1132)  Invalid semaphore id
[2016/07/14@00:26:16.996+0200] P-17010      T-140595944453952 I ABL    87: (10839) SYSTEM ERROR: Unable to set semaphore set : semid = 7, errno = 22.
[2016/07/14@00:26:16.996+0200] P-17010      T-140595944453952 I ABL    87: (2252)  Begin transaction backout.
[2016/07/14@00:26:16.996+0200] P-17010      T-140595944453952 I ABL    87: (2253)  Transaction backout completed.
[2016/07/14@00:26:17.002+0200] P-17010      T-140595944453952 I ABL    87: (453)   Logout by batchclnt on batch.
[2016/07/14@00:26:17.002+0200] P-17010      T-140595944453952 I ABL        (1132)  Invalid semaphore id
[2016/07/14@00:26:17.002+0200] P-17010      T-140595944453952 I ABL        (10839) SYSTEM ERROR: Unable to get value of semaphore set : semid = 5, errno = 22.
[2016/07/14@00:26:17.002+0200] P-17010      T-140595944453952 I ABL        (-----) semLockLog_2: semValue val = -1
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (2527)  Disconnecting dead user 87.
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (1132)  Invalid semaphore id
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (10839) SYSTEM ERROR: Unable to set semaphore set : semid = 7, errno = 22.
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (1132)  Invalid semaphore id
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (10839) SYSTEM ERROR: Unable to get value of semaphore set : semid = 5, errno = 22.
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (-----) semLockLog_2: semValue val = -1
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (5292)  SYSTEM ERROR: The broker is exiting unexpectedly, beginning Abnormal Shutdown.
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (-----) drexit: Initiating Abnormal Shutdown
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (439)   ** Save file named core for analysis by Progress Software Corporation.
[2016/07/14@00:26:19.903+0200] P-3966       T-140549975136064 I BROKER  0: (15192) The database will complete shutdown within approximately 60 seconds.
Verified Answer
  • > Is there a relation between -Mm and semaphores ?

    No. But error 10839 could be a result of memory violation (or of memory leak) and increase of the -Mm could affect the likelihood of the error.

    > Is there an increase in the number of sempahores used by OpenEdge 11.6 compared to OpenEdge 10.2B on linux ?

    No

    Check promon/R&D/debghb/6/16. Semaphores

    Semaphore sets are allocated by primary database broker. The -Mm is a parameter of login broker. Strictly speaking it's the diffrent processes.

All Replies
  • > Is there a relation between -Mm and semaphores ?

    No. But error 10839 could be a result of memory violation (or of memory leak) and increase of the -Mm could affect the likelihood of the error.

    > Is there an increase in the number of sempahores used by OpenEdge 11.6 compared to OpenEdge 10.2B on linux ?

    No

    Check promon/R&D/debghb/6/16. Semaphores

    Semaphore sets are allocated by primary database broker. The -Mm is a parameter of login broker. Strictly speaking it's the diffrent processes.

  • Agree with George.

    It seems de problem happens during disaster recovery step. Try to truncate bi before start the database.