Can I run a 10.2a process in the middle of my 10.1b session? - Forum - OpenEdge General - Progress Community

Can I run a 10.2a process in the middle of my 10.1b session?

 Forum

Can I run a 10.2a process in the middle of my 10.1b session?

  • I am running open edge 10.1b.  We switched platforms, to something Titanium.  Web services were not available for the new platform until v10.1c.   Open edge 10.2a is available for our new platform.

    I want to run a 10.2a process from my 10.1b production system.  I dont need a 10.2a db connection.  How do I do this?

    I tried

         os-command silent /dlc10.2a/bin/mpro XYZZ123.p(input tt-table, output ls-string).

    This did not work.

    I know yall need a whole lot more information, but is this possible?

    If I were in Windows, I would run an appserver, and be done with it.  I am in UNIX.  A unix appserver is not available to me.

  • While the configuration isn't totally clear, it sure sounds like an AppServer problem. Or Webspeed, but that is AppServer in OE10.

    There are various kinds of Unix remote execution facilities of varying security, but that certainly isn't something that one would normally plunk in the middle of ABL code.

    Sonic could be an alternative to AppServer.

    It might help if you described the configuration a bit more clearly and give us a bit more insight about what kind of process you are trying to run, how often it needs to run, what inputs and outputs it has, etc.

    Webservices?

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • You can start the process like you are doing. You cannot pass parameters that way though. You will need to use temp-files for passing the data. And pass the name of the temp-file in -param. -param is accessible from the AVM with SESSION:PARAMETER. You can easily write and read the contents of the temp-table using the XML-WRITE / XML-READ methods.