10.0B05 & SAX - Forum - OpenEdge General - Progress Community
 Forum

10.0B05 & SAX

  • Does anybody know when SAX-WRITER was introduced in Progress, I am stuck with Progress 10.0B05 and SAX-READER works fine but not SAX-WRITER, thats an unknown widget

    Thanks

  • According to http://www.oehive.org/VersionHistory 10.0A for SAX-WRITER.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Hi Thomas

    yes I seen that site also, but I can tell you its not included in 10.0B05 AIX-64bits, the reader is, the write is not, so I guess it's 10.1A

  • I have confirmed that 10.1A provided  SAX Writer support.

    -Joanne

  • Confirmed that it was the _first_ release to provide it?

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Yes.  10.1A provided the initial support for SAX Writer.

    - Joanne

  • Thanks.  I'll change the OE Hive list to reflect that.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Having confirmed that you need 10.1A at least, I suppose the question is, why are you "stuck" on 10.0B?  That's a 5 year old release and there is no functional reason not to be running 10.2A, unless you don't have source ... which seems unlikely since you are seemingly writing code.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • aah well, that is not a mather of choice :-)

  • Actually, it is a matter of choice unless you have no source and have lost your relationship with the vendor.  Other than that, it is always a matter of choice.  Now, perhaps you have one of those vendors who says, "You are on version X of our software and we have only certified that on 10.0B, so you can't upgrade it you want our support."  If that is why you think you have no choice, then you still have the choice of screaming and yelling at the vendor about how stupid this is and how important it is for you not to be stuck on a 5 year old version of Progress.  And, you have the choice of whether or not to care about their support if they are going to have such a stupid policy.  There are lots of alternatives.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com