10.2B server, 10.2A clients ? - Forum - OpenEdge General - Progress Community

10.2B server, 10.2A clients ?

 Forum

10.2B server, 10.2A clients ?

  • Can I have 10.2A clients attaching to a 10.2B server ? And can a 10.2B runtime  run 10.2A .r code ?

    Julian

  • jmls wrote:

    Can I have 10.2A clients attaching to a 10.2B server ? And can a 10.2B runtime  run 10.2A .r code ?

    Julian

    What kind of server? AppServer? Database server? What kind of connection?

    The only thing that is certain is that you cannot make a shared memory connection from a 10.2A client to a 10.2B database server.

    10.2B can certainly run 10.2A rcode. It can even run 10.1x rcode.

  • I am unable to run my Advanced GUI application on any deployment box that is running 10.2B. It will run under OEA but not under Personal Db, Workgroup DB, Client Networking, etc. Basically, I installed OEA 10.2B, upgraded the infragistics controls, updated assemblies references and then compiled code. I then copied all .r code, *.resx, infragistics dll's and assemblies.xml to a fresh install of Workgroup DB 10.2B. When I run my app it crashes with the protrace showing it crashing in the clrbridge. Opened up a call with TS but no resolution yet.

    Has anyone seen this problem? Is anyone successfully running an Advanced GUI app on 10.2B using a Workgroup DB or Personal DB runtime?

  • That sounds like a very different issue that is more than deserving of its own thread.  Tacking it on to this thread will result in your problem being lost and unremarked upon since the subject describes an entirely different question from yours.

    --
    Tom Bascom
    tom@wss.com

  • Thanks.