Inactive window, focus lost on WS2012R2 - Forum - OpenEdge General - Progress Community

Inactive window, focus lost on WS2012R2

 Forum

Inactive window, focus lost on WS2012R2

This question is not answered

Hi
We're migrating our OE 11.5 (32bits) client application side to Citrix XenApp 7.15/Windows2012R2 (from Citrix XenApp 6.5/Windows2008R2).
We're facing some weird happening where some windows/browser get inactive once data loaded. This is not all the time but pretty frequent. By inactive I mean that the current window we're working on has lost focus and might be moved backward. We can easily spot that as on ws2012R2 the windows frame is getting dark color once active whereas it becomes light color.
We've managed to reproduce the case using RDP session on Windows2012R2.
We're in touch with some expert in order to get that sorted/explained but haven't found anything obvious so far.
We've not yet tested a newer OE client version.
We do use ADM2 (but not always).
Does it rings any bell to anyone ?
Thanks
Denis

All Replies
  • Is this what's happening?

    knowledgebase.progress.com/.../P186860

  •  

    Disable RemoteFX graphics -> Set GPO on AD or Local Computer Policy

    Computer Configuration/Policies/Admin Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment: Use advanced RemoteFX graphics for RemoteApp – Disabled

    Regards Jari Kuosmanen

  • Thanks Steven. This is not exactly same as it happens with WS2012R2 but not WS2008R2. During our testing there was no UI interaction (only application window displayed) and windows doesn't always get activated. Also nothing faced with client running on Windows 7. Anyway symptom are pretty similar.

  • progress_problem01.JPG
    progress_problem02.JPG
    The same happens for a customer of me. If I connect to the remote-desktop, starts the application, then I close the terminal session and log in again to the remote-desktop, I will have a blank window.
     
    Could that be the same problem?
     
    Windows server 2012R2
     
    //Geir Otto
     
  • Waiting Microsoft fixes

    RemoteAPP after windows 10 update 1803 are slow and right mouse button is not responding (it reacts only sometimes)

    https://social.technet.microsoft.com/Forums/en-US/f3e9852b-393c-4aa0-9d2f-961a82cfc603/remoteapp-after-windows-10-update-1803-are-slow-and-right-mouse-button-is-not-responding-it-reacts?forum=winserverTS&prof=required

    So we are fixed problem on our customer servers disabling RemoteFX graphics on RDP servers (Windows 2012R2 and Windows 2016.

    Disable RemoteFX graphics -> Set GPO on AD or Local Computer Policy

    Computer Configuration/Policies/Admin Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment: Use advanced RemoteFX graphics for RemoteApp – Disabled

    Regards Jari Kuosmanen

     

  • Thanks Jari. Looking at the blog doesn't seem similar to our case. Also quickly checked the policy and RemoteFX graphics is not enabled on our WS 2012R2.

    Rgds

    Denis

  • Appendix A: Frequently Asked Questions and Troubleshooting Tips

    docs.microsoft.com/.../ff817615(v=ws.10)

    How can I tell if my Remote Desktop session is using RemoteFX?

    You can confirm that your Remote Desktop session is using RemoteFX as follows:

       Check the event log inside the virtual machine. Event ID 2 in the Microsoft-Windows-RemoteDesktopServices-RdpCoreTS/Admin event source is written to the event log with the following text “Remote Desktop Protocol will use RemoteFX module to connect to the client computer. RemoteFX module is being used based on the server configuration, client configuration, and network connection.”

       If the Start Menu shows the Shut Down button, you are using RemoteFX. If you are not using RemoteFX, Log off will appear on the Start Menu.

    Regards

    Jari Kuosmanen