Pacific AppServer and BIGIP F5 reverse Proxy - Forum - OpenEdge General - Progress Community

Pacific AppServer and BIGIP F5 reverse Proxy

 Forum

Pacific AppServer and BIGIP F5 reverse Proxy

This question is answered

We are trying to connect from a webClient using hServer:Connect("-URL HTTPS://xxxx.yyyy.no/apsv"). When doing this using HTTP://<localip>:8090/apsv it works swell, but when trying to connect using the HTTPS and the PROXY server that revert it to http://localip:8090/apsv, we get an error like:

Unable to communicate with AIA. The web server returned an http status code of 404 (9328).

if we try the this from a web browser:

https://xxxx.yyyy.no/apsv 

we get this:

{"AdapterType":"APSV","Connections":[]}

Do anyone know if we have to do something special on the BIGIP F5 ? Or other places?

Verified Answer
  • Shouldnt be a problem between load balancer or reverse proxy.

    This is what I did while configuring nginx load balancer

    upstream pasoe {

                  #ip_hash;

                  server localhost:9811;

                  server localhost:6811;

                                                                  }

       server {

             listen 83;

           location /    {                            

                                                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

                                                proxy_pass http://pasoe;

                                                                              }            

                                   }

    The URL would be http://<load balancer IP Address::83/apsv

    Haven't tried this for HTTP'S, but should be similar.

    Regards,

    Irfan

All Replies
  • If you are using defaults certificate, then you might want to provide "-nohostverify" in your connection parameter.

    Regards,

    Irfan

  • It seems like the proxy manager added their certificate using mkhashfile.bat... I got the same error when trying -nohostverify

    //Geir Otto

  • So did you try to do the same thing having the load balancer for HTTP protocol ? If you did that and you only see the problem HTTP's then I think some configuration problem with the load balancer.

    Regards,

    Irfan

  • Are you saying that we need to setup load balancer ? What will the workers.properties do for this setting?

  • Will a proxy server be seen as a load balancer?

  • Shouldnt be a problem between load balancer or reverse proxy.

    This is what I did while configuring nginx load balancer

    upstream pasoe {

                  #ip_hash;

                  server localhost:9811;

                  server localhost:6811;

                                                                  }

       server {

             listen 83;

           location /    {                            

                                                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

                                                proxy_pass http://pasoe;

                                                                              }            

                                   }

    The URL would be http://<load balancer IP Address::83/apsv

    Haven't tried this for HTTP'S, but should be similar.

    Regards,

    Irfan

  • But do I need to use loadbalancing if I want to do proxy reversing? I will try this tomorrow :-) thanks !!

    Sendt fra min iPad

    Den 15. jun. 2017 kl. 20.38 skrev Irfan <bounce-isyed@community.progress.com>:

    Update from Progress Community
    Irfan

    Shouldnt be a problem between load balancer or reverse proxy.

    This is what I did while configuring nginx load balancer

    upstream pasoe {

                  #ip_hash;

                  server localhost:9811;

                  server localhost:6811;

                                                                  }

       server {

             listen 83;

           location /    {                            

                                                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

                                                proxy_pass http://pasoe;

                                                                              }            

                                   }

    The URL would be http://<load balancer IP Address::83/apsv

    Haven't tried this for HTTP'S, but should be similar.

    View online

     

    You received this notification because you subscribed to the forum.  To unsubscribe from only this thread, go here.

    Flag this post as spam/abuse.

  • Nope, you dont need to. All I am saying is that is the same approach.

    Regards,

    Irfan

  • Got it to work. the F5 manager did something wrong... now it works.