Can version 11.1 and 11.3 co-exist? - Forum - OpenEdge Development - Progress Community

Can version 11.1 and 11.3 co-exist?

 Forum

Can version 11.1 and 11.3 co-exist?

  • I just installed 11.3, and 11.1 application is now giving Invalid Cast error. 11.3 seems OK.

  • Two thoughts:

    1) make sure you're using the updated infragistics version in your assemblies.xml file

    2) re-compile to get the new Infragistics version into the .NET references in the r-code

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • 11.1 application needs to stay referencing the corresponding Infragistics version. Like I mentioned, 11.3 version of the the application referencing the corresponding version of Infragistics seems OK.

  • 11.3 and 11.1 should be using different sets of R-code.

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • The two versions of the application are using separate r-code.

  • Then I have never seen the issue you're describing -  frequently using 11.1, 11.2 and 11.3 in parallel

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • It looks like the 11.3 install did something odd. All my 11.1 project under 11.1 OE Architect are displaying 11.3 as the version, and the install points to 11.3. Is this some sort of registry setting?

  • Hi Joe,

    Can you please open a support case for this issue? It is definitely not expected behavior -- something is not right.

    Thanks,

    Roberta

  • Are the two installs using separate directories and workspaces?
     
     
    From: jquerijero [mailto:bounce-jquerijero@community.progress.com]
    Sent: Wednesday, January 29, 2014 11:25 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: Can version 11.1 and 11.3 co-exist?
     
    Reply by jquerijero

    It looks like the 11.3 install did something odd. All my 11.1 project under 11.1 OE Architect are displaying 11.3 as the version, and the install points to 11.3. Is this some sort of registry setting?

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Separate workspace.

  • What files should I include?

  • Which directory did you install 11.1 into?
    Which directory did you install 11.3 into?
     
    From: jquerijero [mailto:bounce-jquerijero@community.progress.com]
    Sent: Wednesday, January 29, 2014 11:43 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: Can version 11.1 and 11.3 co-exist?
     
    Reply by jquerijero

    Separate workspace.

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • No need to attach files to start. We'd start with a screen-sharing session if that works for you. Thanks!

  • For anyone who is wondering how this came out:

    The project in the OE 11.1 workspace evidently was inadvertently opened with the 11.3 PDSOE and was automatically upgraded.

    Creating a new project and copying the files from the old project into it resolved the problem. Now that we know the cause, this is a cleaner way to correct it:

    1. Delete the affected project from the workspace. Do not select the "Delete project contents on disk (cannot be undone)" check box.

    2. Import the same project using "File > Import... > General > Existing Projects Into Workspace".

    This information has been added to the knowledge base in article 000046419, The wrong OpenEdge version and installation directory are displayed in PDSOE project properties.