Provider moved to TLS 1.2 and appserver can't work with them anymore - Forum - OpenEdge Development - Progress Community

Provider moved to TLS 1.2 and appserver can't work with them anymore

 Forum

Provider moved to TLS 1.2 and appserver can't work with them anymore

This question is answered

Greetings.

Classic Appserver 11.5, windows..

Our provider for signing documents, moved to TLS 1.2 just today (as commanded by SAT government agency, same thing as IRS), and my appserver app started throwing 9318 errors with errno 0.

Also, provider uses following ciphers:

TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (0xc030)
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (0xc02f)
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 (0xc028)
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256 (0xc027)

Reading knowledgebase found TLS 1.2 is available since 11.6... so 

I need to upgrade to 11.7, ...  do I need to keep in mind another thing as far as ciphers goes?

Is there some guide to move from 11.x to 11.7?

(I'm currently working on setting up a v12 pasoe, but the rush is to keep the 11.x app running for some weeks more...)

Your prompt answer will be very appreciated...

Verified Answer
All Replies