Messaging Apps using ClientConnect and ServerConnect from PASOE - Forum - OpenEdge Development - Progress Community

Messaging Apps using ClientConnect and ServerConnect from PASOE

 Forum

Messaging Apps using ClientConnect and ServerConnect from PASOE

This question is not answered

My understanding is that within PASOE the only operating mode supported for JMS messaging is "brokerconnect", right?

I have code like this that attempts to connect to a messaging broker with the "clientconnect" mode but works unreliably:

   RUN jms/ptpsession.p PERSISTENT SET h_Session ("-SMQConnect").

I think Progress intends for this code to be switched over to the brokerconnect.  The "brokerconnect" mode requires that the JMS generic broker/adapter to be running (probably on the PASOE server).  That involves changing the statement above to the following: RUN jms/ptpsession.p PERSISTENT SET h_Session ("-H localhost -S 5162").

Here are the KB articles: 

 

The interesting thing is that my original ("clientconnect") code does NOT seem to fail consistently in PASOE.  In fact it works surprisingly well, until it doesn't.

To prove it works, here is process explorer showing that PASOE started some client connect "symbiont" processes:

... And here is the agent log showing that a connection is being made via "-SMQConnect" :

...

[18/12/28@11:16:23.038-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run beginSession in jms/ptpsession.p [Main Block - que/SqlTransfer/CreateTransferSession.p @ 244]
[18/12/28@11:16:23.038-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run calcStartup [beginSession - jms/impl/session.p @ 1582]
[18/12/28@11:16:23.054-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run getConnectionMetaData "? ?" [beginSession - jms/impl/session.p @ 1621]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run getConnectionValues "10.2B" [beginSession - jms/impl/session.p @ 1626]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run getFactoryMetaData "? ?" [getConnectionValues - jms/impl/session.p @ 1674]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Using connection values: 26,null,true,,true,false,-1,-1,false,0,false,false,,10000,0,30,false,60,0,20,0,,APP_SqlTrans,ufp,GRPOED001,localhost" [getConnectionValues - jms/impl/session.p @ 1677]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "true" [getConnectionValues - jms/impl/session.p @ 1686]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run setDeliveryMode "yes yes" [getConnectionValues - jms/impl/session.p @ 1687]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "true" [getConnectionValues - jms/impl/session.p @ 1693]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "false" [getConnectionValues - jms/impl/session.p @ 1696]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "false" [getConnectionValues - jms/impl/session.p @ 1707]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "false" [getConnectionValues - jms/impl/session.p @ 1713]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "false" [getConnectionValues - jms/impl/session.p @ 1716]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func stringToLogical "false" [getConnectionValues - jms/impl/session.p @ 1731]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogSetId "172.31.23.71::cc1::56676::d909dbd81ecb39f4:-457a7fe4:167f58ef56e:-7ff3" [beginSession - jms/impl/session.p @ 1629]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run setID in jms/impl/errorhndlr.p "172.31.23.71::cc1::56676::d909dbd81ecb39f4:-457a7fe4:167f58ef56e:-7ff3" [beginSession - jms/impl/session.p @ 1630]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogSetID "172.31.23.71::cc1::56676::d909dbd81ecb39f4:-457a7fe4:167f58ef56e:-7ff3" [setID - jms/impl/errorhndlr.p @ 184]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Connection: -SMQConnect" [beginSession - jms/impl/session.p @ 1631]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Func getBrokerURL [beginSession - jms/impl/session.p @ 1632]
[18/12/28@11:16:23.064-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run getBrokerURL "?" [getBrokerURL - jms/impl/session.p @ 754]
[18/12/28@11:16:23.069-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Broker: " [beginSession - jms/impl/session.p @ 1632]
[18/12/28@11:16:23.069-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Domain: ptp" [beginSession - jms/impl/session.p @ 1633]
[18/12/28@11:16:23.069-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Symbiont Mode: yes" [beginSession - jms/impl/session.p @ 1634]
[18/12/28@11:16:23.069-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Fault Tolerant: no" [beginSession - jms/impl/session.p @ 1636]
[18/12/28@11:16:23.069-0500] P-005284 T-006584 2 AS-8 4GLTRACE       Run LogMsg "2 Client Persistence: no" [beginSession - jms/impl/session.p @ 1637]

...

So my confusion is about the mixed messages I'm getting from PASOE. The KB say it doesn't work.  But it does for a while.  Then it fails.

This is unfortunate behavior.  If the all connections are unsupported (aside from brokerconnect ) then they should consistently fail and generate a meaningful error that says why.  I have been able to deploy code thru pre-production environments and do a significant amount of testing to confirm that everything is working.  But things eventually fail when the PASOE server is under load, and that is when we finally discover that "clientconnect" was unsupported all along.

Is there a reason why we get these mixed messages when doing messaging from PASOE?  Is Progress planning to fix clientconnect at some point?  It is certainly a more simple configuration than trying to get the JMS generic broker/adapter running on a PASOE server.  It would be nice to hear some clarification on this subject.  Perhaps there aren't many who use OpenEdge PASOE along with the OpenEdge JMS generic adapter.

All Replies
  • I thought "BrokerConnect" was NOT supported with PASOE. We have been using "BrokerConnect" for 15 years and when we moved to PASOE I am pretty sure e were told we could no longer use. We ended up moving all of our jms code to a GUI cient.