Updateable browser enabling only the first column - Forum - OpenEdge Development - Progress Community

Updateable browser enabling only the first column

 Forum

Updateable browser enabling only the first column

This question is answered

11.7.2 ChUI, Windsow 10

Deploying to 10.2b AIX ChUI

The following code results in only tt.f1 being enabled in the browser.

What am I doing wrong?


define temp-table tt no-undo field f1 as character field f2 as character. define query q1 for tt. define browse b1 query q1 display tt enable all with 5 down no-row-markers. define frame f1 b1. if not temp-table tt:has-records then do: create tt. assign tt.f1 = "Value 1" tt.f2 = "Value 2". end. open query q1 for each tt. enable all with frame f1. wait-for end-error of frame f1.
Verified Answer
  • Are you trying to move to the next column with the Tab key? Try using Ctrl-G to move to the next column and Ctrl-U to move to the previous column.

All Replies
  • Are you trying to move to the next column with the Tab key? Try using Ctrl-G to move to the next column and Ctrl-U to move to the previous column.

  • And thank you for the simple reproducible. That's always a huge help.

  • Yes, I was using the Tab key. Your suggestion did the trick.

    It's been a while since I've worked with updateable browsers and it may have been in GUI.

    Thank you Matt and you're welcome, I know how beneficial a concise usable example is.