How do I pass progress startup parameters to the ANT jobs or PCT ? - Forum - OpenEdge Development - Progress Community

How do I pass progress startup parameters to the ANT jobs or PCT ?

 Forum

How do I pass progress startup parameters to the ANT jobs or PCT ?

This question is answered

Hi All,

How do I pass  progress startup parameters such as -inp, -T etc  to the build xml ? Or what is equivalent to these parameters in build.xml ?

Sometimes I am getting error "More than < value > characters in a single statement--use -inp parm" while performing PCTCompile task and dont know how to fix this.

Thanks,

Atul Dalvi

Verified Answer
  • PCTCompile inherits from PCTRun, so for your specific error I would guess you'd use the inputChars parameter which maps on to the OpenEdge -inp as detailed in the documentation here github.com/.../PCTRun.  Anything which isn't specified there you could just add to a .pf file and pass to PCTCompile with the paramFile parameter.  Again, it's all there in the documentation.

  • +1

    It's also possible to use <Option name="xxx" value="yyy" /> (value being optional)

  • Based on your second issue you are not setting graphicalMode - which means you are starting a character client, the character client uses the propath from the WinCharStartup section of the ini file.

    I expect both problems will be solved if you add graphicalMode="true" to PCTCompile

All Replies
  • PCTCompile inherits from PCTRun, so for your specific error I would guess you'd use the inputChars parameter which maps on to the OpenEdge -inp as detailed in the documentation here github.com/.../PCTRun.  Anything which isn't specified there you could just add to a .pf file and pass to PCTCompile with the paramFile parameter.  Again, it's all there in the documentation.

  • +1

    It's also possible to use <Option name="xxx" value="yyy" /> (value being optional)

  • Hi All,

    I am facing few more issues while using the PCTCompile on the whole source code.

    Issue 1 - I think the tool is not able to understand the preprocessor values.

    [PCTCompile] Error compiling file abc.p in included file jrnl.i at line 229 column 5

    [PCTCompile]     run {&GetComputerName} (input-output vBUF,

    [PCTCompile] ----^

    [PCTCompile] ** Unable to understand after -- "run". (247)

    [PCTCompile] ** Invalid statement. (254)

    Issue 2 - This is something related to the widget size

    [PCTCompile] Error compiling file abc.w at line 0 column 0

    [PCTCompile] &ANALYZE-SUSPEND _VERSION-NUMBER UIB_v9r12 GUI

    [PCTCompile] -^

    [PCTCompile] **The size phrase specified for BROWSE BR_IGR is not large enough. (4023)

    I think both the issues are related to the .ini file setting. I have added same .ini file from the development environment.

    If I compile all the programs from development environment  then no issue but from this tool it is failing and logging above errors.

    Build xml screenshot -

    <PCTCompile destDir="\Project\CompileCodeTest" dlcHome="D:\OpenEdge\116" relativePaths="False" forceCompile="False" paramFile="\abc.pf">

    <Option name="-ininame" value="\abc.ini" />

    Pls help

  • I don't think the tool is to blame. The settings in the ini files are an integral part of your application so if you don't include them in PCTCompile that your omission.

  • 1. "The tool" is simply starting a progress session with the propath you specify and compiling. If your source is not compiling, it is because you are not providing a correct propath.

    2. If you need a graphical compile (prowin), you will need to set graphicalMode (github.com/.../PCTRun)

  • No, I have added the correct Propaths and the same ini file path.

    The other programs in the same folder and sub folder are getting compiled only these .w files are facing issues.

  • Based on your second issue you are not setting graphicalMode - which means you are starting a character client, the character client uses the propath from the WinCharStartup section of the ini file.

    I expect both problems will be solved if you add graphicalMode="true" to PCTCompile

  • Yes, graphicalMode="true" resolved 2nd issue.

    Thanks.