Suppressing the OE splash screen for a single session - Forum - OpenEdge Development - Progress Community

Suppressing the OE splash screen for a single session

 Forum

Suppressing the OE splash screen for a single session

This question is answered

I'm working on some 11.3 Win 7 code that'll be run in a "Dos"ish batch mode (-b) session, and return some values via stdout.

I would like to suppress the standard PSC splash screen for the start of these sessions.

The KB's I found so far show how to permanently suppress these screens, which isn't what I want, I need per call suppression. 

Can this be done? 

Verified Answer
  • Your problem is the mpro.bat script. Take a look at it, it shows

    if "%DISPBANNER%"=="no" goto NOBANNER

      type "%DLC%"\hello

    So if you wish to continue using this script, set env var DISPBANNER=no. Alternatively, you could use the mbpro.bat or bpro.bat scripts.

  • Hello,

    The mpro command is a batch file (mpro.bat).
    There is an environment variable called DISPBANNER that you can set to no to suppress the banner.
    You could also make your own batch file if you need to remove the display of the version information.
    Alternatively, you could call _progres.

    I hope this helps.
    ---
    On 5/30/2014 10:47 AM, Tim Kuehn wrote:

    To clarify -

    I'm running a program in batch mode, which means it's the char client.

    The command I'm running is:

    mpro -pf %DIRPATH%/pf/FileName.pf -basekey "INI" -ininame %DIRPATHE%/bin/IniName.ini -param %1

    There is a "splash screen" (or text chars) which shows at the start of the session - that's what I'm trying to eliminate as I'm using the output of this batch file to transfer information to an unrelated program through stdout.

    This is what I'm seeing when the program starts up, and I want gone:

           @@@@@@   @@@@@@   @@@@@@@   @@@@@   @@@@@@   @@@@@@@   @@@@@    @@@@@

          @     @  @     @  @     @  @     @  @     @  @        @     @  @     @

         @     @  @     @  @     @  @        @     @  @        @        @

        @@@@@@   @@@@@@   @     @  @  @@@@  @@@@@@   @@@@@     @@@@@    @@@@@

       @        @   @    @     @  @     @  @   @    @              @        @

      @        @    @   @     @  @     @  @    @   @        @     @  @     @

     @        @     @  @@@@@@@   @@@@@   @     @  @@@@@@@   @@@@@    @@@@@

                              Progress Software Corporation

                                       14 Oak Park

                               Bedford, Massachusetts 01730

                                       781-280-4000

          PROGRESS is a registered trademark of Progress Software Corporation

                                 Copyright 1984-2013

                           by Progress Software Corporation

                                 All Rights Reserved

    OpenEdge Release 11.3.1 as of Thu Sep 19 19:02:23 EDT 2013

  • In the batch scripts in %dlc%/bin for pro and mpro and friends, is the following
    if "%DISPBANNER%"=="no" goto NOBANNER
       type "%DLC%"\hello
     
    what happen if you set that variable to 'no'.
     
    If you run _progress directly (ie from proenv or cli), there's no banner.
     
    -- peter
     
     
    From: Mike Fechner [mailto:bounce-mikefechner@community.progress.com]
    Sent: Friday, 30 May, 2014 10:50
    To: TU.OE.Development@community.progress.com
    Subject: [Technical Users - OE Development] AW: Suppressing the OE splash screen for a single session
     
    11.3.1? ;-)

    This is not considered the splash screen, if you ask me.

    Von meinem Windows Phone gesendet

    Von: Tim Kuehn
    Gesendet: ‎30.‎05.‎2014 16:47
    An: TU.OE.Development@community.progress.com
    Betreff: RE: [Technical Users - OE Development] Suppressing the OE splash screen for a single session

    To clarify -

    I'm running a program in batch mode, which means it's the char client.

    The command I'm running is:

    mpro -pf %DIRPATH%/pf/FileName.pf -basekey "INI" -ininame %DIRPATHE%/bin/IniName.ini -param %1

    There is a "splash screen" (or text chars) which shows at the start of the session - that's what I'm trying to eliminate as I'm using the output of this batch file to transfer information to an unrelated program through stdout.

    This is what I'm seeing when the program starts up, and I want gone:

           @@@@@@   @@@@@@   @@@@@@@   @@@@@   @@@@@@   @@@@@@@   @@@@@    @@@@@

          @     @  @     @  @     @  @     @  @     @  @        @     @  @     @

         @     @  @     @  @     @  @        @     @  @        @        @

        @@@@@@   @@@@@@   @     @  @  @@@@  @@@@@@   @@@@@     @@@@@    @@@@@

       @        @   @    @     @  @     @  @   @    @              @        @

      @        @    @   @     @  @     @  @    @   @        @     @  @     @

     @        @     @  @@@@@@@   @@@@@   @     @  @@@@@@@   @@@@@    @@@@@

                              Progress Software Corporation

                                       14 Oak Park

                               Bedford, Massachusetts 01730

                                       781-280-4000

          PROGRESS is a registered trademark of Progress Software Corporation

                                 Copyright 1984-2013

                           by Progress Software Corporation

                                 All Rights Reserved

    OpenEdge Release 11.3.1 as of Thu Sep 19 19:02:23 EDT 2013

  • This comes from  type "%DLC%"\version in the .bat file. You'll have to edit that one out if you want it gone, or else write your own script.

  • Hello Tim,
     
    That should be from the version file in %DLC%.
     
    Just rename the version file.
     
    Twitter
    Facebook
    LinkedIn
    Google+
     
     
    From: Tim Kuehn [mailto:bounce-timk519@community.progress.com]
    Sent: Friday, May 30, 2014 11:26 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: [Technical Users - OE Development] Suppressing the OE splash screen for a single session
     

    As a final note - the big banner's gone, I'm still seeing this:

      OpenEdge Release 11.3.1 as of Thu Sep 19 19:02:23 EDT 2013

    I'm presuming this is from the binary and there's no way to get rid of it.....


    PROGRESS SOFTWARE CORPORATION
    14 Oak Park Drive | Bedford, MA 01730 | USA
    PHONE +1 781 280-3008
    richards@progress.com

    www.progress.com

  • In the script is this:
    :NOBANNER
       type "%DLC%"\version
       "%PROEXE%" -1 %1 %2 %3 %4 %5 %6 %7 %8 %9
     
    Just change it to this:
    :NOBANNER
       "%PROEXE%" -1 %1 %2 %3 %4 %5 %6 %7 %8 %9
     
    Twitter
    Facebook
    LinkedIn
    Google+
     
     
    From: Garry Hall [mailto:bounce-gih@community.progress.com]
    Sent: Friday, May 30, 2014 11:30 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: [Technical Users - OE Development] Suppressing the OE splash screen for a single session
     

    This comes from  type "%DLC%"\version in the .bat file. You'll have to edit that one out if you want it gone, or else write your own script.


    PROGRESS SOFTWARE CORPORATION
    14 Oak Park Drive | Bedford, MA 01730 | USA
    PHONE +1 781 280-3008
    richards@progress.com

    www.progress.com

All Replies
  • Write two functions to programmatically toggle the value of the nosplash string between yes and no in the following section:

    HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1C\Startup

    The code in the following KB should help in doing this:

    knowledgebase.progress.com/.../21529

  • Alternatively, use a .ini file with the nosplash=yes to start the session without the splash and another without the nosplash=yes in the startup section to start the sessions with the splash.

  • Is the .ini file something I can point to when the session is started?

  • Yes. Use:

    -basekey INI -ininame <name of ini file>

    In 11.4 you will be able to use the new -nosplash startup parameter to suppress the splash screen.

  • Ok, I'm taking the plunge - I've created a .ini file and added this to it:

      [Startup]

      nosplash=yes

    and I'm still getting the "splash". I've also added this to a [WinChar Startup] section, and I still get the splash message.

    This is for a command/DOS type session on Windows 7. Does this not work in this situation, or is it only for GUI sessions?

  • Is it case sensitive?

    NoSplash=yes

    Also, do you definitely reference the ini in your startup? You may have to fully path it. If the ini isn't there you don't get any errors it just loads without it.

  • It's running the .ini as there's a required propath setting in the file and that's working.

    I tried changing the case in both sections - still no go.

  • Hello Tim,
     
    Add the following to the command line which initiates the Progress client:
    -basekey INI –ininame <path to the ini file you made>
     
    Twitter
    Facebook
    LinkedIn
    Google+
     
     
    From: Tim Kuehn [mailto:bounce-timk519@community.progress.com]
    Sent: Friday, May 30, 2014 10:03 AM
    To: TU.OE.Development@community.progress.com
    Subject: RE: [Technical Users - OE Development] Suppressing the OE splash screen for a single session
     

    Ok, I'm taking the plunge - I've created a .ini file and added this to it:

      [Startup]

      nosplash=yes

    and I'm still getting the "splash". I've also added this to a [WinChar Startup] section, and I still get the splash message.

    This is for a command/DOS type session on Windows 7. Does this not work in this situation, or is it only for GUI sessions?


    PROGRESS SOFTWARE CORPORATION
    14 Oak Park Drive | Bedford, MA 01730 | USA
    PHONE +1 781 280-3008
    richards@progress.com

    www.progress.com

  • Rich - I've got that already, although I've got "INI" in there instead of INI - does that make a difference for anything?

  • Quotes are fine and it's not case sensitive.

    It sounds like you're using the character client. The character client doesn't display a splash screen at startup. Are you using _progres.exe or prowin32.exe? Only prowin32.exe will display the splash screen.

    When you say that you created an ini file, did you start with a copy of progress.ini or did you create a file and add only the nosplash setting? You should start with progress.ini and modify it. If you make a copy with a new name you have to use the -ininame parameter to tell the client to load the ini file. By default it only tries to load a file named progress.ini.

    You said earlier that you were going to be using batch mode (-b). The splash screen isn't displayed in batch mode.

    This is all very confusing.

  • You can check whether it's picking up your ini file by pressing Ctrl-Alt-Shift-F1 after the client starts (not in a batch session, of course). A dialog appears which shows where the settings were found.

  • To clarify -

    I'm running a program in batch mode, which means it's the char client.

    The command I'm running is:

    mpro -pf %DIRPATH%/pf/FileName.pf -basekey "INI" -ininame %DIRPATHE%/bin/IniName.ini -param %1

    There is a "splash screen" (or text chars) which shows at the start of the session - that's what I'm trying to eliminate as I'm using the output of this batch file to transfer information to an unrelated program through stdout.

    This is what I'm seeing when the program starts up, and I want gone:

    <Progress ASCII Letters>

    Progress Software Corporation

    14 Oak Park
    Bedford, Massachusetts 01730
    781-280-4000

    PROGRESS is a registered trademark of Progress Software Corporation
    Copyright 1984-2013
    by Progress Software Corporation
    All Rights Reserved

    OpenEdge Release 11.3.1 as of Thu Sep 19 19:02:23 EDT 2013

  • 11.3.1? ;-)

    This is not considered the splash screen, if you ask me.

    Von meinem Windows Phone gesendet

    Von: Tim Kuehn
    Gesendet: ‎30.‎05.‎2014 16:47
    An: TU.OE.Development@community.progress.com
    Betreff: RE: [Technical Users - OE Development] Suppressing the OE splash screen for a single session

    To clarify -

    I'm running a program in batch mode, which means it's the char client.

    The command I'm running is:

    mpro -pf %DIRPATH%/pf/FileName.pf -basekey "INI" -ininame %DIRPATHE%/bin/IniName.ini -param %1

    There is a "splash screen" (or text chars) which shows at the start of the session - that's what I'm trying to eliminate as I'm using the output of this batch file to transfer information to an unrelated program through stdout.

    This is what I'm seeing when the program starts up, and I want gone:

           @@@@@@   @@@@@@   @@@@@@@   @@@@@   @@@@@@   @@@@@@@   @@@@@    @@@@@

          @     @  @     @  @     @  @     @  @     @  @        @     @  @     @

         @     @  @     @  @     @  @        @     @  @        @        @

        @@@@@@   @@@@@@   @     @  @  @@@@  @@@@@@   @@@@@     @@@@@    @@@@@

       @        @   @    @     @  @     @  @   @    @              @        @

      @        @    @   @     @  @     @  @    @   @        @     @  @     @

     @        @     @  @@@@@@@   @@@@@   @     @  @@@@@@@   @@@@@    @@@@@

                              Progress Software Corporation

                                       14 Oak Park

                               Bedford, Massachusetts 01730

                                       781-280-4000

          PROGRESS is a registered trademark of Progress Software Corporation

                                 Copyright 1984-2013

                           by Progress Software Corporation

                                 All Rights Reserved

    OpenEdge Release 11.3.1 as of Thu Sep 19 19:02:23 EDT 2013

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • Mike Fechner
    11.3.1? ;-)

    This is not considered the splash screen, if you ask me.

    Ok, call it what you will - I still want it gone. 

  • Your problem is the mpro.bat script. Take a look at it, it shows

    if "%DISPBANNER%"=="no" goto NOBANNER

      type "%DLC%"\hello

    So if you wish to continue using this script, set env var DISPBANNER=no. Alternatively, you could use the mbpro.bat or bpro.bat scripts.