OpenEdge Explorer - Edit database connection - Forum - OpenEdge Development - Progress Community

OpenEdge Explorer - Edit database connection

 Forum

OpenEdge Explorer - Edit database connection

This question is answered

Linux 11.6

Could anyone tell me where I can find Other Parameters in the Edit Database Connection setup?

I need to load some data into a db and I would like to test this feature. I also need to set -E as connection parameter.

https://documentation.progress.com/output/ua/OpenEdge_latest/index.html#page/pdsoe%2Fadd-2fedit-openedge-database-connection-profile-wi.html%23wwID0E63PM

//Geir Otto

Verified Answer
  • Support gave me the answare :-)

    ________________

    That is indeed where it has to be set. You don't have to restart adminserver or Fathom. Just set the parameters in DLC/startup.pf. After I did that in my tests, I then was able to load the data without error.

    There is in fact a defect logged for this, that the parameters can't be set under OEM.

    ______________________

    Hopefully it will be fixed Cool

All Replies
  • The title of this post is 'OpenEdge Explorer' when I think you mean Progress Developer Studio?

  • ...

  • Aaah so there it is no,  I did mean from Openedge Explorer. The reason is that I have a database server (and no 4gl), and I want to load data on the server. If I use my Developer studio, I am connected through network connection, and that is not fast. I need to load the data on the server.

     

    It seems like the Openedge Explorer has almost the same way of making the database connection, but no Other Parameters. I need to connect using -E

  • Aha - your link to the PDSOE documentation threw me off the scent.

    By any chance are the .d file trailers containing numeric and date formats respected? I know that the GUI data administration reads them and then complains, but maybe some lessons were learnt when creating the OpenEdge Explorer version so that it adjusts it's session for the duration of the load?

  • I am using Norwegian setup, so normally -E and -d dmy, but I am not sure what I had when the dump was done, except that the dumped file is like this:

    PSC

    filename=xxxxx

    records=0000000062312

    ldbname=winnkaf

    timestamp=2018/09/10-14:08:11

    numformat=44,46

    dateformat=dmy-1950

    map=NO-MAP

    cpstream=ISO8859-1

    .

    And if I try to load it wihtin OEExplorer, it fails...

  • I got this answare from support....

    _____________________________________

    I get the same behaviour as you in OEM. I tried setting the parameters in the database connection configuration (under Other arguments), but since they are client parameters they just get ignored there.

    Of course the behaviour is easy enough to resolve if using the prowin/prowin32 client. However, this situation - loading a .d which was dumped with a different num parameters - is possibly a use-case that OEM doesn't cover. It may be that it isn't possible, and so a client session and DataAdministration will have to be used.

    I am researching further, and will get back to you. If you need to load the .d in the meantime, I advise to use the standard Data Administration utility from a prowin client.

    ____________________________________________

    would it be possible to startup the OE explorer by changing DLC\startup.pf ?

  • Support gave me the answare :-)

    ________________

    That is indeed where it has to be set. You don't have to restart adminserver or Fathom. Just set the parameters in DLC/startup.pf. After I did that in my tests, I then was able to load the data without error.

    There is in fact a defect logged for this, that the parameters can't be set under OEM.

    ______________________

    Hopefully it will be fixed Cool