Problem with smartdatabrowse, migrating from 9.1C to 10.2B - Forum - OpenEdge Development - Progress Community

Problem with smartdatabrowse, migrating from 9.1C to 10.2B

 Forum

Problem with smartdatabrowse, migrating from 9.1C to 10.2B

This question is not answered
pedir-ayuda-errores-427-y-382.pdf

Hello, we have just upgraded from 9.1C to 10.2B.

In several smartdatabrowse we have a curious problem.
When a second record is added, we receive a Error 427 followed by two 382.

There is already a first record in the browse, but the message says there are no records.

The KB article S000031130 is about a similar problem between 9.1D and 10.2B, but using VIEW-AS COMBO-BOX phrase, which is not the case.

The data saves Ok, but it's annoying for the users and confusing for the IT staff.

I´m attaching a pdf with screen captures.


Perhaps somebody know what can we do and help us,

Ezequiel Montoya
Lima - Perú
All Replies
  • How exactly did you perform the migration from 9.1C to 10.2B ?

    Did you also carry over the 9.1C version of the ADM2 code or not ?

    (Carrying over the old version of the framework normally avoids this type of issue)

  • Hello Frank, we have a customized ADM2 and we use it in some applications, like some toolbars. For the others, we used the standard 9.1C ADM2.

    Now we are doing the same: We use the customized ADM2 and the standard 10.2B in C:\PROGRESS\OpenEdge\src

    Ezequiel Montoya
    Lima - Perú
  • Problem being that standard 9.1C ADM2 <> standard 10.2B ADM2.   You either need to carry forward the 9.1C version and use that or you will have to do some conversion to use the 10.2B version.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com