How to use a hyperlink in a dataslot of type URL - Forum - OpenEdge BPM - Progress Community

How to use a hyperlink in a dataslot of type URL

 Forum

How to use a hyperlink in a dataslot of type URL

  • Hello,

    I have an issue about using a hyperlink as a dataslot value.

    In the attached file I included the details of my question.

    I think it is simple, but you have to know it...

    Thanks in advance!!

    Regards,

    René

    How to create in hyperlink in a dataslot of type URL.doc

  • Simple way is to make URL dataslot as non editable either from Form Editor> URL dataslot textfeild >Right Click> Properties> Deselect Editable field.

    The editable property is also available under Application> Dataslot tab> Dataslot Properties section. If you use this method, remove the dataslot from the form page and readd it so that tags for the dataslot will be regenerated.

    Let me know if this works for you.  There is one more complex type to achive the requirement but anyways if the above does not works for you, we can discuss it.

    Thank you,

    Parshuram

  • Hi Parshuram,

    Thanks for your suggestion, but it doesn't work.

    Attached you will find the file in which the steps are descriped I took.

    Do you have another suggestion, or did I something wrong?

    Thanks!

    Regards,

    René

  • The procedure you have done is correct. Please try to remove the dataslot on form by closing the Form Editor > Reopening the Form Editor>Drag and drop the URL dataslot from DataSources pane>Dataslots > User Dataslots> the url dataslot. Redploy the application.

    You may also try adding a new dataslot and see if works.

    Thank you,

    Parshuram

    408-330-3438

  • Hi Parshuram,

    I tried your suggested method, but this still doesn't work...

    I asked my collegea Sipke Bosma to do the same on his machine. And guess, this works perfectly...

    After that I did a new installation of the BPM studio on client site. But this had no effect.

    I'm out of my options. What is the problem, and how can I solve this?

    When this won't work with such a simple thing, what will be the consequences when I have non working issues on complex things?

    Regards,

    René

  • Please provide me your contact details so that i can look into this issue on your setup.

    Parshuram

    Phone: +1 408-330-3438

  • Hi,

    My phone number is +31 6 129 733 13.

    E-mail adress: rsturing@vanmeijel.nl.

    I hope this is sufficient for you to contact me.

    Regards,
    René

  • Hi,

    The suggested solution is working now.

    Difference is that I created a new workspace, with an webapplication in this workspace it is working fine.

    Question: which setup / configuration have to be done to make this possible in the existing workspaces?

    Thanks!

    Regards,

    René