OE Webserver Will NOT Publish - Forum - Mobile - Progress Community

OE Webserver Will NOT Publish

 Forum

OE Webserver Will NOT Publish

  • I was working on a mobile project when it froze publishing. I could not do anything not even end the task. After about 30 minutes I finally powered down my laptop but no longer could get into my workspace...I assume it is corrupted. I then created a new workspace and imported my projects just fine. However, I cannot publish any BE. PDSOE never even tries. Upon looking at the .log I see the following entries. Does anyone have any ideas?

    !ENTRY com.openedge.pdt.server 4 0 2013-04-09 17:59:19.252

    !MESSAGE Failed to stop OE Web Server restmgr1 - roger-m6700

    !STACK 1

    org.eclipse.core.runtime.CoreException: The runtime 11.2 for OpenEdge server restmgr1 OE Web Server 11.2 at roger-m6700 is not installed at C:\Progress\OpenEdge

    at com.openedge.pdt.server.broker.OpenEdgeBroker.getExplorerServerConfiguration(OpenEdgeBroker.java:212)

    at com.openedge.pdt.server.broker.OpenEdgeBroker.getAdminServerConnection(OpenEdgeBroker.java:238)

    at com.openedge.pdt.server.broker.OpenEdgeBroker.fetchUBrokerService(OpenEdgeBroker.java:343)

    at com.openedge.pdt.server.broker.OpenEdgeBrokerBehavior$1.run(OpenEdgeBrokerBehavior.java:232)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    !SUBENTRY 1 com.openedge.pdt.server 4 0 2013-04-09 17:59:19.252

    !MESSAGE The runtime 11.2 for OpenEdge server restmgr1 OE Web Server 11.2 at roger-m6700 is not installed at C:\Progress\OpenEdge

    !ENTRY com.openedge.pdt.server 4 0 2013-04-09 17:59:19.301

    !MESSAGE Failed to stop AppServer restbroker1 - roger-m6700

    !STACK 1

    org.eclipse.core.runtime.CoreException: The runtime 11.2 for OpenEdge server restbroker1 AppServer 11.2 at roger-m6700 is not installed at C:\Progress\OpenEdge

    at com.openedge.pdt.server.broker.OpenEdgeBroker.getExplorerServerConfiguration(OpenEdgeBroker.java:212)

    at com.openedge.pdt.server.broker.OpenEdgeBroker.getAdminServerConnection(OpenEdgeBroker.java:238)

    at com.openedge.pdt.server.broker.OpenEdgeBroker.fetchUBrokerService(OpenEdgeBroker.java:343)

    at com.openedge.pdt.server.broker.OpenEdgeBrokerBehavior$1.run(OpenEdgeBrokerBehavior.java:232)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    !SUBENTRY 1 com.openedge.pdt.server 4 0 2013-04-09 17:59:19.302

    !MESSAGE The runtime 11.2 for OpenEdge server restbroker1 AppServer 11.2 at roger-m6700 is not installed at C:\Progress\OpenEdge

    !ENTRY org.eclipse.core.jobs 2 2 2013-04-09 17:59:20.744

    !MESSAGE Job found still running after platform shutdown.  Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.wst.server.core.internal.Server$StopJob

    !ENTRY org.eclipse.core.jobs 2 2 2013-04-09 17:59:20.754

    !MESSAGE Job found still running after platform shutdown.  Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.wst.server.core.internal.Server$StopJob

  • I totally uninstalled OE11.2, made sure directories deleted and reinstalled 11.2.

    I still cannot make changes to existing projects and have the BE published. I tried creating a new workspace and then a new mobile app but cannot even do that. The dropdown box for the Mobile Project is empty so the wizard will not allow me to continue.

    At this point I am dead in the water waiting to hear from PTS.

  • Hi Roger Blanchar,

    Can you please provide log file for PDSOE after you reproduced the issue. log file location was : /.metadata/.log

    It will be helpfull if you set debug level in eclipse.ini file (eclipse.ini file location is: C:\Progress\DeveloperStudio3.7\eclipse\eclipse.ini), open this file and add -Doeide.logging=4 at end of the file and save.

    Now start the PDSOE and reproduce the scenario. Now log file will have all debug traces.

    Thanks and Regards

    Mogileswara Rao

  • I have worked with Brian in TS. The issue appears to be when importing a mobile project from another workspace the restmanager is not updated so the publishing does not occur.