Resources not showing under Resources tab in Openedge Management Console. - Forum - Mobile - Progress Community

Resources not showing under Resources tab in Openedge Management Console.

 Forum

Resources not showing under Resources tab in Openedge Management Console.

  • Hi,

       I am using Openedge 11.3 . I am not able to see any resources under resources tab in Openedge Management Console. But able to see them under server view in developer studio. when trying to start Appserver(rest) broker,  I got   "Some internal problem came in the response received from OpenEdge Explorer. Please check the log file for more details." error message. In the system I am using , Openedge 11.0 and apache tomcat is also installed . This error came after using 11.0 for some time. Later I stopped admin services for 11.0 and started admin services for 11.3 . I restarted my system , deleted environment variables pointing to 11.0 or apache tomcat. Nothing worked.

    Please let me know if I need to do change any configurations or settings.

    Thanks ,

    Madhavi V.

  • Please provide the admserv.log and the ads0.exp files(if any) generated in the OpenEdge working directory.

  • Hi,

       Attached is the admin server log . I have masked some details in the log like ip, host name etc. Also please see below exception which was there in local host log under WRK directory.  I have copied oerm.war to tomcat installation directory , un-deployed it and deployed it again. Restarted admin services. But below exception is still coming .


    Sep 23, 2013 5:59:18 PM org.apache.catalina.core.ApplicationContext log
    SEVERE: Servlet OERestAdapter threw unload() exception
    javax.servlet.ServletException: Servlet.destroy() for servlet OERestAdapter threw exception
    at org.apache.catalina.core.StandardWrapper.unload(StandardWrapper.java:1485)
    at org.apache.catalina.core.StandardWrapper.stopInternal(StandardWrapper.java:1822)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:232)
    at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5463)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:232)
    at org.apache.catalina.core.ContainerBase$StopChild.call(ContainerBase.java:1575)
    at org.apache.catalina.core.ContainerBase$StopChild.call(ContainerBase.java:1564)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:722)
    Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(ArrayList.java:604)
    at java.util.ArrayList.get(ArrayList.java:382)
    at org.apache.cxf.jaxrs.JAXRSServiceImpl.getName(JAXRSServiceImpl.java:101)
    at org.apache.cxf.endpoint.ManagedEndpoint.getObjectName(ManagedEndpoint.java:99)
    at org.apache.cxf.management.jmx.InstrumentationManagerImpl.unregister(InstrumentationManagerImpl.java:253)
    at org.apache.cxf.endpoint.ServerImpl.destroy(ServerImpl.java:192)
    at org.apache.cxf.bus.managers.ServerRegistryImpl.preShutdown(ServerRegistryImpl.java:90)
    at org.apache.cxf.bus.managers.CXFBusLifeCycleManager.preShutdown(CXFBusLifeCycleManager.java:95)
    at org.apache.cxf.bus.CXFBusImpl.shutdown(CXFBusImpl.java:231)
    at org.apache.cxf.transport.servlet.CXFNonSpringServlet.destroyBus(CXFNonSpringServlet.java:159)
    at org.apache.cxf.transport.servlet.CXFNonSpringServlet.destroy(CXFNonSpringServlet.java:154)
    at org.apache.catalina.core.StandardWrapper.unload(StandardWrapper.java:1464)
    ... 11 more

  • Have you found any solution?

    We are facing the same problems.