Not able to setup Pacific Appserver in Studio to work with Tomcat Properly - Forum - Mobile - Progress Community

Not able to setup Pacific Appserver in Studio to work with Tomcat Properly

 Forum

Not able to setup Pacific Appserver in Studio to work with Tomcat Properly

This question is not answered

I am working on creating the demo using the OE 11.6/Telerik . I am facing one technical problem .

I am using Progress Developer Studio 11.6 . I have created a Pacific Application Server on which I am building the Web Application using Kendo UI .

I created an open edge project which is running on the Pacific Appserver “oepas1” .  I was able to go to Tomcat Page fine .

After putting some business logic in the Restful API , I was supposed to see the details of API in the browser by putting   http://localhost:8810/SportsKendo/rest/sports/Item in the browser . But I did not got the correct response , instead I got error “403 - Forbidden: the server refuses to fullfill the client's request - GET /SportsKendo/rest/sports/Item” .

To fix the above error , I tried resetting/changing  the password of Pacific Application server in OpenEdge Explorer - Resources - OpenEdge - Pacific Application Server - oepas1 - Configuration and then I even lost the connection to the sever . and then I even lost the connection to the sever .

Now I get message “PAS connection Failed – Server returned 401 Unauthorized for https://localhost:8811/oemanager/” , when I press button “Test Connection” .

I have tried using the password from Pacific Application Server Properties from Developer Studio  for fields “webPassword” and “tomcatMgrPassword” in the below screen but it does not work .

Please help me know ,

1)      How to reset the password / or to get the correct password for both the Tomcat manager login and OpenEdge Manaher Login .

2)      How to make  http://localhost:8810/SportsKendo/rest/sports/Item work in browser once above is fixed .

All Replies
  • Singh,

    What time zone are you in?  Please contact me at rperdiga@progress.com and I will take a look on your environment using GoToMeeting this Thursday or Friday.

    Regards,

    Ricardo Perdigao

  • Please make sure you have installed the Service Pack 2 for 11.6 (available now) before we meet.

    Assuming this is your first App and you have not gone too far:  It would much easier for us to start from a fresh (never touched) OE install (where no parameters were changed), but if not possible: No worries.

    Tomorrow (Thursday), I am available from 11am EST to 4pm EST and from 8pm EST to 12am EST.   Let me know a time that works for you and I will send you a meeting invite.

    It is hard (for me at least) to debug/fix it without looking at it ... Others might be able to help you without looking into your install ...

    All the best!

    Ricardo

  • Hi Singh,

    The PASOE will give you a forbidden error if you try to get a resource that doesn't exist. I don't expect it has anything to do with username / password of your tomcat manager. Please change these back to the defaults (tomcat/tomcat).

    Also please share a screenshot of you project in PDSOE so that I can check whether there are things incorrect / missing.

    It might be your URL (Case sensitive) or an unpublished REST service. Did you select the publish to root or publish to webapp option when creating your OE Project in PDSOE?

  • Hello Ricardo , Many Thanks for stepping in . I am in EST time zone . I am available today anytime after 12 PM  . Please email me the invite at smitesh@corelogic.com . I will try to install Service Pack 2 for 11.6 before the call .

    This is a fresh Install of OE11.6 64 bit on my system .

    The only other thing which i want to mention here ( Although i don't think this should have any issue .)  is that i also have OE 10.2B 32 bit on my system , which i have installed in a different folder . I need it to run a dot net project on my system which connects to OE using ODBC and direct app server call . The Visual Studio only recognize the driver from OE 32 bit , thus i need it .

    Although OE 11.6 is running fine the OE Explorer is also running fine in 11.6 .

    Thanks Again .

  • Hi Singh,

    your URL is missing the transport value "rest".  The proper URL syntax would be "hostname:port/.../item".  Notice the "rest" right after the hostname:port/.

    With PASOE the syntax is always http(s)://hostname:port/<transport-type>.

    The valid transports types are:  rest, soap, apsv, and web

    Please let us know what you find.  Roy

  • You can have many versions of OE installed on a single machine; they just need to be in their own folders (to state the obvious).

    You need to be careful with (at least)

    - adminserver services (all use the same port and so only 1 starts from services). I set all my services to manual start and start them via ProEnv when I need an admin server (proadsv –start)

    - DLC environment variables. I don't use one, and run the pertinent ProEnv  if I need it set. Yoou can also set it in INI files.

    From 11.5 on, on Windows, you can have a 32- and 64-bit version of the same OE release installed on the same machine. So you can have 11.6 64 and 32 simultaneously installed (and I'd recommend that rather than sticking with 10.2B for bitness reasons).

  • Hi Singh,

    not sure what the forum did to my URL syntax?

    It should read "localhost:8810/.../Item"

    Let see if the forum shortens it again?

  • Your URL should read:

    localhost:8810/.../Item

    You have the "rest" word twice on your URL ...  Please let us know if this fix it ...

  • Hello All ,

    Many thanks for your suggestions .

    I installed Service Pack 2 for 11.6 thinking it could fix it , but after installing service pack 2 OpenEdge Explorer stopped working . I then thought it could be because of two versions of openedge on my system and then i decided to uninstall both OE 11.6 64 bit and OE10.2B 32 bit from mys syatem .

    After uninstalling both , i again installed OE 11.6 . I check OpenEdge Explorer and it worked . Then i again installed Service pack 2 for 11.6 and again OE Explorer stopped working .  It gives message "Unable to connect for http://localhost:9090/ "

    I am not sure that service pack will fic the issue but , is somebody has any idea that service pack is messing the OE explorer then it will be helpfull .

  • Hi Mitesh,

    Can you please check if the admin service is up and running. If not can you please start the admin service either from proenv or from the Windows services and try accessing the OpenEdge Management or Explorer.

                      proenv>proadsv -start

    Use below command for verifying the status of the admin service from proenv.

                      proenv>proadsv -query

    P.S: As part of the service pack (11.6.2) installation the admin service process will be stopped (I assume you might have received a confirmation message asking for the process to be stopped by installer).

    Hope this helps.

    Thanks and Regards,

    Anil Kumar.

  • Hi Mitesh,

    To solve OpenEdge Explorer problem after installing 11.6.2 service pack follow the instructions mentioned by Anil. Once the problem is solved, let us know how you deployed (i.e. deploy as ROOT or WebApp) your application to PAS. If you didn’t change any deployment options while creating New ABL Web App project, then deployment is ROOT by default. In this case the URL to access the service is: http://<host>:<port>/rest/<servicesURI/<resourceURI>. If your application is deployed as WebApp, then the URL to access the service is: http://<host>:<port>/<WebAppName>/rest/<serviceURI>/<resourceURI> . You can check the service URI from edit service dialog before checking in browser.  

    Thanks,

    Sanjeev.

  • You can have many versions of OE installed on a single machine; they just need to be in their own folders (to state the obvious).
     
    You need to be careful with (at least)
    - adminserver services (all use the same port and so only 1 starts from services). I set all my services to manual start and start them via ProEnv when I need an admin server (proadsv –start)
     
    - DLC environment variables. I don't use one, and run the pertinent ProEnv  if I need it set. Yoou can also set it in INI files.
     
    From 11.5 on, on Windows, you can have a 32- and 64-bit version of the same OE release installed on the same machine. So you can have 11.6 64 and 32 simultaneously installed (and I'd recommend that rather than sticking with 10.2B for bitness reasons).
     
  • Hi Mitesh,
     
    To solve OpenEdge Explorer problem after installing 11.6.2 service pack follow the instructions mentioned by Anil. Once the problem is solved, let us know how you deployed (i.e. deploy as ROOT or WebApp) your application to PAS. If don’t change any deployment options while creating New ABL Web App project, then deployment is ROOT by default. In this case the URL to access the service is: http://<host>:<port>/rest/<servicesURI/<resourceURI>. If your application is deployed as WebApp, then the URL to access the service is: http://<host>:<port>/<WebAppName>/rest/<serviceURI>/<resourceURI> . You can check the service URI from edit service dialog before checking in browser.  
     
    Thanks,
    Sanjeev.