OpenEdge Mobile Express - - - error - Forum - Mobile - Progress Community

OpenEdge Mobile Express - - - error

 Forum

OpenEdge Mobile Express - - - error

  • Hello.

    When creating the most simple Mobile Express-project, I get every time the same error (version 11.4./ Progress Developer Studio 4.3)

  • Hi,
     
    Can you please share the snapshot of the error you are seeing. Also, can you please any logs if you find (located under .metadata folder in workspace directory).
     
    Were you able to access and create new mobile apps from Mobile App Builder environment directly (appdesigner.rollbase.com) with the credentials provided in Preferences page?
     
    Thanks and Regards,
    Anil Kumar.
     
    From: teppo_55 [mailto:bounce-teppo_55@community.progress.com]
    Sent: Thursday, November 13, 2014 8:39 PM
    To: TU.Mobile@community.progress.com
    Subject: [Technical Users - Mobile] OpenEdge Mobile Express - - - error
     
    Thread created by teppo_55

    Hello.

    When creating the most simple Mobile Express-project, I get every time the same error (version 11.4./ Progress Developer Studio 4.3)

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Can you please share the snapshot of the error you are seeing. Also, can you please any logs if you find (located under .metadata folder in workspace directory).
     
    image
     
    image
     
    image
     
     
    image
     
     
     
     
     
    --- There is no .metadata folder .
     
    Were you able to access and create new mobile apps from Mobile App Builder environment directly (appdesigner.rollbase.com) with the credentials provided in Preferences page?
     
    --- Not yet.
     
    ---------------------------|--------------------
    Teppo Määttänen____| TR-Tiimi Oy
    Consultant_________| Struerintie 1
    teppo @ trtiimi.fi____| 30100 FORSSA
    int-358-50-5748 226 | www.trtiimi.fi
  • HI,
     
    Regarding the current problem (Can't find response parameter '<>' in a rest service), we have an intermittent issue in 11.4 environment and we are trying to fix this issue in the upcoming version(s) of PDS OE.
    Is this always reproducible?
     
    Can you please try creating another Express Project and see if it works.
     
    Some additional information on current problem: Express project failed to create a Business Entity with complete schema of the selected table (in this case person). The temp-table in the include file (under Express project) would have ABL logic as follows (which is incomplete):
     
    DEFINE TEMP-TABLE ttperson BEFORE-TABLE bttperson.
    DEFINE DATASET dsperson FOR ttperson.
     
    In this case, the mobile service which gets created as part of Express Project is built against wrong Business Entity file and an error is shown on UI for the same.
     
    Thanks and Regards,
    Anil Kumar.
     
    From: teppo_55 [mailto:bounce-teppo_55@community.progress.com]
    Sent: Thursday, November 13, 2014 9:07 PM
    To: TU.Mobile@community.progress.com
    Subject: [Technical Users - Mobile] Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by teppo_55
    Can you please share the snapshot of the error you are seeing. Also, can you please any logs if you find (located under .metadata folder in workspace directory).
     
    image
     
    image
     
    image
     
     
    image
     
     
     
     
     
    --- There is no .metadata folder .
     
    Were you able to access and create new mobile apps from Mobile App Builder environment directly (appdesigner.rollbase.com) with the credentials provided in Preferences page?
     
    --- Not yet.
     
  • clip_image002
    clip_image004
     
     
    image
     
    ---------------------------|--------------------
    Teppo Määttänen____| TR-Tiimi Oy
    Consultant_________| Struerintie 1
    teppo @ trtiimi.fi____| 30100 FORSSA
    int-358-50-5748 226 | www.trtiimi.fi
    ---------------------------|--------------------
     
    From: Anil Kumar
    Sent: Thursday, November 13, 2014 5:59 PM
    Subject: RE: [Technical Users - Mobile] Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by Anil Kumar
    HI,
     
    Regarding the current problem (Can't find response parameter '<>' in a rest service), we have an intermittent issue in 11.4 environment and we are trying to fix this issue in the upcoming version(s) of PDS OE.
    Is this always reproducible?
     
    Can you please try creating another Express Project and see if it works.
     
    Some additional information on current problem: Express project failed to create a Business Entity with complete schema of the selected table (in this case person). The temp-table in the include file (under Express project) would have ABL logic as follows (which is incomplete):
     
    DEFINE TEMP-TABLE ttperson BEFORE-TABLE bttperson.
    DEFINE DATASET dsperson FOR ttperson.
     
    In this case, the mobile service which gets created as part of Express Project is built against wrong Business Entity file and an error is shown on UI for the same.
     
    Thanks and Regards,
    Anil Kumar.
     
    From: teppo_55 [mailto:bounce-teppo_55@community.progress.com]
    Sent: Thursday, November 13, 2014 9:07 PM
    To: TU.Mobile@community.progress.com
    Subject: [Technical Users - Mobile] Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by teppo_55
    Can you please share the snapshot of the error you are seeing. Also, can you please any logs if you find (located under .metadata folder in workspace directory).
     
    image
     
    image
     
    image
     
     
    image
     
     
     
     
     
    --- There is no .metadata folder .
     
    Were you able to access and create new mobile apps from Mobile App Builder environment directly (appdesigner.rollbase.com) with the credentials provided in Preferences page?
     
  • Hi,
     
    Seems there is problem with the OE Webserver (tomcat). Can you please provide the tomcat logs located under OpenEdge installation directory.
     
    Thanks and Regards,
    Anil Kumar.
     
    From: teppo_55 [mailto:bounce-teppo_55@community.progress.com]
    Sent: Friday, November 14, 2014 9:19 PM
    To: TU.Mobile@community.progress.com
    Subject: [Technical Users - Mobile] Now "original" error from OpenEdge Mobile Express //// Re: Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by teppo_55
    clip_image002
    clip_image004
     
     
    image
     
    ---------------------------|--------------------
    Teppo Määttänen____| TR-Tiimi Oy
    Consultant_________| Struerintie 1
    teppo @ trtiimi.fi____| 30100 FORSSA
    int-358-50-5748 226 | www.trtiimi.fi
    ---------------------------|--------------------
     
    Sent: Thursday, November 13, 2014 5:59 PM
    Subject: RE: [Technical Users - Mobile] Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by Anil Kumar
    HI,
     
    Regarding the current problem (Can't find response parameter '<>' in a rest service), we have an intermittent issue in 11.4 environment and we are trying to fix this issue in the upcoming version(s) of PDS OE.
    Is this always reproducible?
     
    Can you please try creating another Express Project and see if it works.
     
    Some additional information on current problem: Express project failed to create a Business Entity with complete schema of the selected table (in this case person). The temp-table in the include file (under Express project) would have ABL logic as follows (which is incomplete):
     
    DEFINE TEMP-TABLE ttperson BEFORE-TABLE bttperson.
    DEFINE DATASET dsperson FOR ttperson.
     
    In this case, the mobile service which gets created as part of Express Project is built against wrong Business Entity file and an error is shown on UI for the same.
     
    Thanks and Regards,
    Anil Kumar.
     
    From: teppo_55 [mailto:bounce-teppo_55@community.progress.com]
    Sent: Thursday, November 13, 2014 9:07 PM
    To: TU.Mobile@community.progress.com
    Subject: [Technical Users - Mobile] Now a different error ? ? ? // Re: OpenEdge Mobile Express - - - error
     
    Reply by teppo_55
    Can you please share the snapshot of the error you are seeing. Also, can you please any logs if you find (located under .metadata folder in workspace directory).
     
    image
     
    image
     
    image
     
     
    image