Not possible to send Push messages with HTTP Post triggers on Private Cloud - Forum - Mobile - Progress Community

Not possible to send Push messages with HTTP Post triggers on Private Cloud

 Forum

Not possible to send Push messages with HTTP Post triggers on Private Cloud

  • Hi Ajay,

    Thanks for all options. But the main issue is that after deleting the record and reinstalling the app again, the database-device id remains empty. Any idea? The problem is here, i think...

    My API key is: bfb212c9-5a4c-43e9-8471-6fd44e56f28c

    By the way: We need to send segmented push messages (to a few device-id's). You've suggested not to use this, why? Its a customer requirement, we need to build it in this way, hope that it will work...

  • At the moment im testing the push messages with the dashboard. The post trigger will be step 2 :)

  • Hi Bal,

    I suggested not to use device id just for time until we are able to send basic Push Notification. And about device id coming as empty is an issue because if device id is empty then the push will not be get delivered to device.

    Can you please let us know which device you are using (Android, iOS).

    Regards

    Ajay

  • >By the way: We need to send segmented push messages (to a few device-id's). You've suggested not to use this, why? Its a customer requirement, we need to >build it in this way, hope that it will work...

    You can add your own filter fields to the device database in the dashboard. You would need to populate those values via the UpdateDevice API call. See the doc at http://docs.mobile.rollbase.com/documentation/backendservices/push/ for this and also for the Filtering section (which is how you'd send messages to only certain devices).

    Hth,
    -- peter

     
     
     
    From: bal [mailto:bounce-bal@community.progress.com]
    Sent: Wednesday, 03 December, 2014 07:21
    To: TU.Mobile@community.progress.com
    Subject: RE: [Technical Users - Mobile] Not possible to send Push messages with HTTP Post triggers on Private Cloud
     
    Reply by bal

    Hi Ajay,

    Thanks for all options. But the main issue is that after deleting the record and reinstalling the app again, the database-device id remains empty. Any idea? The problem is here, i think...

    My API key is: bfb212c9-5a4c-43e9-8471-6fd44e56f28c

    By the way: We need to send segmented push messages (to a few device-id's). You've suggested not to use this, why? Its a customer requirement, we need to build it in this way, hope that it will work...

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Still having the issue. localStorage.getItem('pushNotificationDeviceID') remains empty. Very very weird...still investigating...

  • Got it, it was due the bug which will be solved in 3.1...The cordova_plugins.js was corrupt...Now testing the trigger..

  • Yes it works!!

    @Ajay: it was idd a typo :)