OE Pas Logging Level - Forum - Community Groups - Progress Community

OE Pas Logging Level

 Forum

OE Pas Logging Level

This question is answered
Capture.PNG

Hi All,

I've been trying to work out how to turn down the logging level in OE Pas and so far with no luck - any help greatly received!  Attached is the kind of output we are currently getting.  I just don't seem able to stop the DEBUG messages. We are on OpenEdge 11.5.1 - thanks in advance!

Thanks,

Mark

Verified Answer
  • Hi Mark,
     
    I have seen this problem when there is no context.xml file (containing logback/context-name) in the oeabl web application’s META-INF folder.
     
    The META-INF/context.xml contains logback/context-name:
    ===
    <Context>
                   <!--  Environment entry to control log file name   -->
                   <Environment name="logback/context-name" type="java.lang.String" value="pas1" override="false" />
    </Context>
    ===
    In WEB-INF/web.xml, there is following entry:
    ===
    <env-entry>
      <env-entry-name>logback/configuration-resource</env-entry-name>
      <env-entry-type>java.lang.String</env-entry-type>
      <env-entry-value>../logging.xml</env-entry-value>
    </env-entry>
    ===
    And in WEB-INF/logging.xml there’s the appender-name:
    ===
          <appender name="FILE-${contextName}" class="ch.qos.logback.core.rolling.RollingFileAppender">
            <append>true</append>
            <prudent>true</prudent>
            <rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">
              <fileNamePattern>${catalina.base}/logs/${contextName}.%d{yyyy-MM-dd}.log</fileNamePattern>
            </rollingPolicy>
            <encoder>
              <!-- add the timestamp as milliseconds to facilitate logfile post processing     -->
              <!--                                                                             -->
              <!-- <pattern>%d{HH:mm:ss.SSS} [%thread] %-5level %logger{36} - %msg%n</pattern> -->
              <pattern>%d{HH:mm:ss.SSS}/%r [%thread] %-5level %logger{36} - %msg%n</pattern>
              <!--                                                                             -->
            </encoder>
          </appender>
        </sift>
      </appender>
    ===
    These entries will cause log to go as per logging.xml setting into <contextName>.<date>.log
     
    When you deploy an oeabl.war file using tcman deploy everything that I have stated above is taken care of.

    However, if you manually deploy by copying an oeabl.war in the webapps folder, context.xml isn’t created (AFAIK) causing logging to go amuck.
     
    Please check if this could be happening in your case too.
     
    Thanks,
    Navneet
     
    From: MarkT [mailto:bounce-MarkT@community.progress.com]
    Sent: Thursday, July 30, 2015 4:08 PM
    To: TU.General@community.progress.com
    Subject: RE: [Community Groups - General] OE Pas Logging Level
     
    Reply by MarkT

    Hi All,

    Anyone know why we can't remove DEBUG within PAS from our console window?

    Thanks,

    Mark

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

All Replies
  • Take a look at the settings in <instance>\conf\logging.properties as well as <instance>\webapps\ROOT \WEB-INF\logging.xml . If not ROOT then another webapp.
     
    From: MarkT [mailto:bounce-MarkT@community.progress.com]
    Sent: Tuesday, 28 July, 2015 10:02
    To: TU.General@community.progress.com
    Subject: [Community Groups - General] OE Pas Logging Level
     
    Thread created by MarkT

    Hi All,

    I've been trying to work out how to turn down the logging level in OE Pas and so far with no luck - any help greatly received!  Attached is the kind of output we are currently getting.  I just don't seem able to stop the DEBUG messages. We are on OpenEdge 11.5.1 - thanks in advance!

    Thanks,

    Mark

    Attachments:
    Capture.PNG
    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi Peter,

    All of the logging within the logging.xml files are commented out.  We've been playing with various settings all afternoon and still don't seem to be able to get rid of the excessive debug logging.

    Thanks,

    Mark

  • Hi,

    We are still having trouble tracking down where this debug setting is so we can stop these debug messages being output to the console. We are starting the Pacific Appserver using the command tcman start.

    This are the files and settings we've tried looking at without luck:


    WRK\oepas1\conf\openedge.properties

    [AppServer.SessMgr]

               agentLogEntryTypes=

               agentLogFile=

               agentLoggingLevel=1

               agentLogThreshold=0

    [AppServer.SessMgr.oepas1]

               agentLogEntryTypes=ASPlumbing,DB.Connects

               agentLogFile=D:\OpenEdge\WRK\oepas1/logs/oepas1.agent.log

               agentLoggingLevel=1

               agentLogThreshold=0

               brkrDebuggerEnabled=0


    WRK\oepas1\conf\appserver.properties

    No reference to debugging/logging


    WRK\oepas1\conf\catalina.properties

    Only some references to log4j and  commons-logging jar files


    WRK\oepas1\conf\server.xml

    No reference to debugging/logging


    WRK\oepas1\conf\server-debug.xml

    Only one reference to debugging

           <!-- feature:begin:AccessLog:on -->

           <Valve className="org.apache.catalina.valves.AccessLogValve"

                  directory="${catalina.base}/logs"

                  prefix="localhost_access_log."

                  suffix=".txt"

                  pattern="debug: %h %l %u %t "%r" %s %b %D" />

           <!-- feature:end:AccessLog:on -->


    WRK\oepas1\conf\logging.properties

    All entries have FileHandler.level set to INFO.


    WRK\oepas1\conf\web.xml

    only reference to debugging I think is disabled

    <servlet>

        <servlet-name>default</servlet-name>

        <servlet-class>org.apache.catalina.servlets.DefaultServlet</servlet-class>

        <init-param>

            <param-name>debug</param-name>

            <param-value>0</param-value>

        </init-param>

        <init-param>

            <param-name>listings</param-name>

            <param-value>false</param-value>

        </init-param>

        <load-on-startup>1</load-on-startup>

    </servlet>


    WRK\oepas1\webapps\ROOT\WEB-INF\logging.xml

            All logger tags are commented


    WRK\oepas1\webapps\oemanager\WEB-INF\logging.xml

           No logger tags


    WRK\oepas1\webapps\hrpo\WEB-INF\logging.xml

           All logger tags are commented


    Are there any other configuration files we can look to turn the debugging level down?

    Thanks

  • Hi All,

    Anyone know why we can't remove DEBUG within PAS from our console window?

    Thanks,

    Mark

  • Hi Mark,
     
    I have seen this problem when there is no context.xml file (containing logback/context-name) in the oeabl web application’s META-INF folder.
     
    The META-INF/context.xml contains logback/context-name:
    ===
    <Context>
                   <!--  Environment entry to control log file name   -->
                   <Environment name="logback/context-name" type="java.lang.String" value="pas1" override="false" />
    </Context>
    ===
    In WEB-INF/web.xml, there is following entry:
    ===
    <env-entry>
      <env-entry-name>logback/configuration-resource</env-entry-name>
      <env-entry-type>java.lang.String</env-entry-type>
      <env-entry-value>../logging.xml</env-entry-value>
    </env-entry>
    ===
    And in WEB-INF/logging.xml there’s the appender-name:
    ===
          <appender name="FILE-${contextName}" class="ch.qos.logback.core.rolling.RollingFileAppender">
            <append>true</append>
            <prudent>true</prudent>
            <rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">
              <fileNamePattern>${catalina.base}/logs/${contextName}.%d{yyyy-MM-dd}.log</fileNamePattern>
            </rollingPolicy>
            <encoder>
              <!-- add the timestamp as milliseconds to facilitate logfile post processing     -->
              <!--                                                                             -->
              <!-- <pattern>%d{HH:mm:ss.SSS} [%thread] %-5level %logger{36} - %msg%n</pattern> -->
              <pattern>%d{HH:mm:ss.SSS}/%r [%thread] %-5level %logger{36} - %msg%n</pattern>
              <!--                                                                             -->
            </encoder>
          </appender>
        </sift>
      </appender>
    ===
    These entries will cause log to go as per logging.xml setting into <contextName>.<date>.log
     
    When you deploy an oeabl.war file using tcman deploy everything that I have stated above is taken care of.

    However, if you manually deploy by copying an oeabl.war in the webapps folder, context.xml isn’t created (AFAIK) causing logging to go amuck.
     
    Please check if this could be happening in your case too.
     
    Thanks,
    Navneet
     
    From: MarkT [mailto:bounce-MarkT@community.progress.com]
    Sent: Thursday, July 30, 2015 4:08 PM
    To: TU.General@community.progress.com
    Subject: RE: [Community Groups - General] OE Pas Logging Level
     
    Reply by MarkT

    Hi All,

    Anyone know why we can't remove DEBUG within PAS from our console window?

    Thanks,

    Mark

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi Navneet,

    Thanks for this, you've solved our problem. We were missing the context.xml file inside META-INF (everything else was fine).

    I thought we did use tcman deploy to deploy the application but I can't be 100% sure. Will definitely make sure it's the way we deploy in the future.

    Once again thanks for this, and we now have a significant performance increase too!