connectivity from OBIEE 11g to MongoDB on linux - Forum - DataDirect Connect - Progress Community

connectivity from OBIEE 11g to MongoDB on linux

 Forum

connectivity from OBIEE 11g to MongoDB on linux

  • A column of a table in a schema should be referenced like this Schema.Table.Column if you prefer this full qualified name. In your case, the first column should be "Users"."Zodiac Mongo Test"."Account Number" if Users is the schema you were using. For the backend I am using for this test against MongoDB 2.6.4, I have to use each of these parts in upper case as they are put in double quotes. I guess you have to do the same for your backend. I am not sure if the case of identifiers is configurable for the backend, though.

    Hope this helps. Good luck!

  • Hi,

    Can some help us in fixing these issue.

    Regards,

    Sreenivasulu.

  • What is the issue?

  • Here you go... If this is not correct can you provide sample statement and see if I can fetch data from setup I did.

    [obiee1171@VTS-OracleLin27 bin]$ ./nqcmd

    -------------------------------------------------------------------------------

             Oracle BI ODBC Client

             Copyright (c) 1997-2013 Oracle Corporation, All rights reserved

    -------------------------------------------------------------------------------

    Give data source name: MongoDB4

    Give user name: CMS

    Give password:

           [T]able info

           Coffeeolumn info

           Drinksata type info

           [F]oreign keys info

           [P]rimary key info

           [K]ey statistics info

           Sleeppecial columns info

           [Q]uery statement

    Select Option: Q

    Give SQL Statement:

           [T]able info

           Coffeeolumn info

           Drinksata type info

           [F]oreign keys info

           [P]rimary key info

           [K]ey statistics info

           Sleeppecial columns info

           [Q]uery statement

    Select Option: Q

    Give SQL Statement: SELECT 0 s_0, "Devices"."Serial Number" s_1, "Periods"."Zodiac Fiscal Year" s_2 FROM "Zodiac Mongo Test" WHERE ("Periods"."Zodiac Fiscal Year" = '2016')

    SELECT 0 s_0, "Devices"."Serial Number" s_1, "Periods"."Zodiac Fiscal Year" s_2 FROM "Zodiac Mongo Test" WHERE ("Periods"."Zodiac Fiscal Year" = '2016')

    2713MongoDB ODBC driver2726MongoDB ODBC driver.2728

    [2713][State: 60] [DataDirect][ODBC 20101 driver]2713MongoDB ODBC driver2726MongoDB ODBC driver.

    Statement preparation failed

    Regards,

    Sreenivasulu.

  • Thanks for raising this thread Sreenivasulu. I recall when I queried MongoDB from OBIEE Admin on Windows, it was required to *clear* that read-only box on the advanced tab based on some emulation issues.  From Linux, the equivalent would be ReadOnly=0.  See if that helps or you can also contact us from the website if you want access to a live technical resource to help.

    Check out my world famous blog on data connectivity

  • Hi Sumit,

    Thanks for the advise. I will check this option and reach out if any others issues.

    Regards,

    Sreenivasulu.

  • Hi Sumit,

    Set the ReadOnly=0 but still same issue.

    Could you suggest how I can reach to live technical resource for assistance. Is it free or will there be any charges.

    [obiee1171@VTS-OracleLin27 bin]$ ./nqcmd

    -------------------------------------------------------------------------------

             Oracle BI ODBC Client

             Copyright (c) 1997-2013 Oracle Corporation, All rights reserved

    -------------------------------------------------------------------------------

    Give data source name: MongoDB4

    Give user name: CMS

    Give password:

           [T]able info

           Coffeeolumn info

           Drinksata type info

           [F]oreign keys info

           [P]rimary key info

           [K]ey statistics info

           Sleeppecial columns info

           [Q]uery statement

    Select Option: Q

    Give SQL Statement: SELECT "CMS"."Users"."Account Number" FROM "Users" ;

    SELECT "CMS"."Users"."Account Number" FROM "Users" ;

    2713MongoDB ODBC driver2726MongoDB ODBC driver.2728

    [2713][State: 60] [DataDirect][ODBC 20101 driver]2713MongoDB ODBC driver2726MongoDB ODBC driver.

    Statement preparation failed

    Give SQL Statement: SELECT "CMS"."Users"."Account Number" FROM "Users"

    SELECT "CMS"."Users"."Account Number" FROM "Users"

    2713MongoDB ODBC driver2726MongoDB ODBC driver.2728

    [2713][State: 60] [DataDirect][ODBC 20101 driver]2713MongoDB ODBC driver2726MongoDB ODBC driver.

    Statement preparation failed

    Regards,

    Sreenivasulu.

  • We do offer free evaluation support options for prospects.  Please fill out the form and include the request in the message - www.progress.com/.../contact

    Check out my world famous blog on data connectivity

  • Hi Sumit,

    That's great thanks for the information. I will fill the form.

    Regards,

    Sreenivasulu.

  • Have you tried to use upper case values for all the values that you put in double quotes?

    BTW, See the numbers instead of text in the error message above? your resource file could not be located by the driver. If your driver .so is under .../lib, the resource .mo should be under .../locale/en_US/LC_MESSAGES unless you use a different locale.

  • Hi,

    Both .so and .mo files are in correct location. Also ran query with upper case still same issue.

    I have USERS tables under CMS schema and have columns like Email, Account Number etc., can you give sample command to test.

    Give SQL Statement: SELECT "CMS"."USERS"."ACCOUNT NUMBER" FROM "USERS" ;

    SELECT "CMS"."USERS"."ACCOUNT NUMBER" FROM "USERS" ;

    2713MongoDB ODBC driver2726MongoDB ODBC driver.2728

    [2713][State: 60] [DataDirect][ODBC 20101 driver]2713MongoDB ODBC driver2726MongoDB ODBC driver.

    Statement preparation failed

    Regards,

    Sreenivasulu.

  • What is your LOCALE environment variable set to?

    If set to anything other than en_US, please add a symbolic link in the ODBC_INSTALL_DIR/locale directory where the name of the link is your locale value and it points to the ODBC_INSTALL_DIR/locale/en_US directory. This should resolve the issue you are having with the driver not being able to find the message files.

    Example:

    LOCALE=en_US.UTF8

    If ODBC Install Dir=/home/users/myuser/odbc80 then run these commands to create the symbolic link:

    cd /home/users/myuser/odbc80

    ln -s /home/users/myuser/odbc80/locale/en_US en_US.UTF8

    Incidentally, the message you are now getting is:

    The evaluation period for this MongoDB ODBC driver has expired.  Please call Progress Software Corporation to obtain a production version of this MongoDB ODBC driver.

    Please use the form to contact our organization to get an extension to your evaluation period.

  • Hi,

    Thanks for the information. I will check the option and get back.

    regarding drivers, Currently we are on testing phase by installing evaluation version once it is successful we will contact for production version.

    Regards,

    Sreenivasulu.

  • Have you tried a column name without spaces to see if the query works?

  • Hi,

    I am able to get data from using simple query from nqcmd. Now I will check from OBIEE Answers and advise.

    select email from users.

    Thanks for the help.

    Regards,

    Sreenivasulu.