Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce - Forum - DataDirect Cloud - Progress Community

Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce

 Forum

Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce

This question is not answered

Hi,

I am getting the following error when creating External Data Source in Salesforce and clicking on Validate & Sync

An error occurred while connecting to the external system. Please try again, or contact your administrator about this error. Attempted to reach this URL: https://service.datadirectcloud.com/api/odata/OracleXE/$metadata. Error received: 409: 222206331The OData Model has not been fully built. Please build the model before trying to make another OData call.

I have configured the Data Source & OData in Progoress Direct Data Cloud and also able to execute query in Progress Direct Data Cloud. All that seems to be working fine.

Looks like I am missing something somewhere. Can anyone please help.

Thanks & Regards,

Ashish

All Replies
  • There seem to have been problems creating the OData model.
     
    19-Aug-2015 07:28:02.020 CONFIG [http-nio-8080-exec-71] [anish@asagarwal.com][oracle][oraclexe][tdlpi2S/kMUmT7ih].[odata_api][getMetadata] exception [token=Error][errorCode=222206760][sqlState=HY000][origin=SERVICE][message=User tried to start OData Model Creation that was already running. DataSourceId: 37893. LoginId: 63909.]
     
    19-Aug-2015 07:35:46.627 CONFIG [http-nio-8080-exec-7] [anish@asagarwal.com][oracle][oraclexe][k8QkkRvB5eNd6ZDO].[odata_api][getMetadata] exception [token=Error][errorCode=222206760][sqlState=HY000][origin=SERVICE][message=User tried to start OData Model Creation that was already running. DataSourceId: 37893. LoginId: 63909.]
     
    Should Ashish use the Management API to create the model? If you want to try creating the OData model through the Management API, here is the URL and payload you’ll need to send.
     
     
    { “refresh” : true }
     
    You’ll also need to supply your Progress and ID through Basic Authentication. Use the following URL to get the OData model status.
     
     
    Thanks,
    John
     
    From: anish@asagarwal.com [mailto:bounce-anishasagarwalcom@community.progress.com]
    Sent: Wednesday, August 19, 2015 3:43 AM
    To: TU.DD.Cloud@community.progress.com
    Subject: [Technical Users - DataDirect Cloud] Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce
     
    Thread created by anish@asagarwal.com

    Hi,

    I am getting the following error when creating External Data Source in Salesforce and clicking on Validate & Sync

    An error occurred while connecting to the external system. Please try again, or contact your administrator about this error. Attempted to reach this URL: https://service.datadirectcloud.com/api/odata/OracleXE/$metadata. Error received: 409: 222206331The OData Model has not been fully built. Please build the model before trying to make another OData call.

    I have configured the Data Source & OData in Progoress Direct Data Cloud and also able to execute query in Progress Direct Data Cloud. All that seems to be working fine.

    Looks like I am missing something somewhere. Can anyone please help.

    Thanks & Regards,

    Ashish

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Oops…wrong payload.
     
    { “restart” : true }
     
    You’ll need a utility, such as Postman, to use the Management API.
     
    Sorry about that,
    John
     
    From: jhobson [mailto:bounce-jhobson@community.progress.com]
    Sent: Wednesday, August 19, 2015 8:14 AM
    To: TU.DD.Cloud@community.progress.com
    Subject: RE: [Technical Users - DataDirect Cloud] Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce
     
    Reply by jhobson
    There seem to have been problems creating the OData model.
     
    19-Aug-2015 07:28:02.020 CONFIG [http-nio-8080-exec-71] [anish@asagarwal.com][oracle][oraclexe][tdlpi2S/kMUmT7ih].[odata_api][getMetadata] exception [token=Error][errorCode=222206760][sqlState=HY000][origin=SERVICE][message=User tried to start OData Model Creation that was already running. DataSourceId: 37893. LoginId: 63909.]
     
    19-Aug-2015 07:35:46.627 CONFIG [http-nio-8080-exec-7] [anish@asagarwal.com][oracle][oraclexe][k8QkkRvB5eNd6ZDO].[odata_api][getMetadata] exception [token=Error][errorCode=222206760][sqlState=HY000][origin=SERVICE][message=User tried to start OData Model Creation that was already running. DataSourceId: 37893. LoginId: 63909.]
     
    Should Ashish use the Management API to create the model? If you want to try creating the OData model through the Management API, here is the URL and payload you’ll need to send.
     
     
    { “refresh” : true }
     
    You’ll also need to supply your Progress and ID through Basic Authentication. Use the following URL to get the OData model status.
     
     
    Thanks,
    John
     
    From: anish@asagarwal.com [mailto:bounce-anishasagarwalcom@community.progress.com]
    Sent: Wednesday, August 19, 2015 3:43 AM
    To: TU.DD.Cloud@community.progress.com
    Subject: [Technical Users - DataDirect Cloud] Getting Error "The OData Model has not been fully built" when trying to configure external data source in Salesforce
     
    Thread created by anish@asagarwal.com

    Hi,

    I am getting the following error when creating External Data Source in Salesforce and clicking on Validate & Sync

    An error occurred while connecting to the external system. Please try again, or contact your administrator about this error. Attempted to reach this URL: https://service.datadirectcloud.com/api/odata/OracleXE/$metadata. Error received: 409: 222206331The OData Model has not been fully built. Please build the model before trying to make another OData call.

    I have configured the Data Source & OData in Progoress Direct Data Cloud and also able to execute query in Progress Direct Data Cloud. All that seems to be working fine.

    Looks like I am missing something somewhere. Can anyone please help.

    Thanks & Regards,

    Ashish

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi John on the POST request I am getting the following message

    {

    error: {

    code: 222207054

    message: {

    lang: "en-US"

    value: "Cannot start the OData Model Creation because it is currently running. Please see the documentation if you wish to restart the creation."

    }-

    }-

    }

    And on the GET Request I am getting the following message

    {

    statusCode: 1

    status: "Working on model."

    percentDone: "0%"

    }

  • Hi John,

    I created a new data source with the same definition in Progress Data Direct and that seems to be working fine in Salesforce. May be something was corrupted in my old data source.

    You may stop looking into this or if you are still interested in investigating further and trying to resolve the issue, I am okay to provide whatever information that you need and try out the solutions that you come up with.

    Cheers,

    Ashish