Salesforce

PASOE agent seems to be terminating unexpectedly

« Go Back

Information

 
TitlePASOE agent seems to be terminating unexpectedly
URL Nameincomplete-pasoe-agent-seems-to-be-terminating-unexpectedly
Article Number000168329
EnvironmentProduct: OpenEdge
Version: 11.7.5
OS: RedHat
Question/Problem Description
PASOE agent seems to be terminating unexpectedly.
Immediately after the PASOE agent PID disappears another is spawned. 
RedHat auditd does not show the PASOE agent PID being killed. 
System messages log does not show any messages related to OE. 
There are no errors in the PASOE logs before the PID disappears. 
Steps to Reproduce
Clarifying Information
Server is not dedicated to OE, it also houses other 3rd-party databases and APIs.
PASOE heap memory was increased but issue persisted.
 
Error Message
Defect Number
Enhancement Number
Cause
The exact cause is not known at this time.
Although issue disappeared after dedicating the server to OE and increasing the number of CPUs.
Seems to be related to machine resource exhaustion. 
Resolution
None at this time.
In this particular environment increasing the number of CPUs and removing all other third-party applications that were consuming resources on the machine seemed to have address the issue. 
Workaround
 
Notes
Keyword Phrase
Last Modified Date3/20/2020 1:13 PM

Powered by