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PASOE sessions stuck in STOPPING state and not getting disconnected

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Information

 
TitlePASOE sessions stuck in STOPPING state and not getting disconnected
URL NamePASOE-sessions-stuck-in-STOPPING-state-and-not-getting-disconnected
Article Number000205025
EnvironmentProduct: OpenEdge
Version: 11.7 to 11.7.10 , 12 to 12.2.6
OS: All supported platforms
Other: PASOE
Question/Problem Description

Some of the PASOE Session Manager sessions are stuck in the STOPPING state.

PASOE Session Manager sessions which are stuck in the STOPPING state are not being cleaned up by the PASOE instance.

Steps to Reproduce
Clarifying Information
The sessions do not disappear after restarting the PASOE Agents.
The PASOE instance is not fully restarted, only the Agents are being trimmed and restarted.
Error Message
Defect NumberOCTA-37463
Enhancement Number
Cause
When a network error occurs while reading the response from the Agent, the session's state is marked as STOPPING, to avoid trying to reuse this session. The session is set in this state with the expectation that the transport layer will handle the network exception, and then shutdown the session. The PASOE instance should clean up these sessions from the session pool automatically, but it is not doing so.
Resolution
Fixed version(s): OpenEdge 12.5, OpenEdge 12.2.7, OpenEdge 11.7.11
Workaround
Restart the PASOE instance to cleanup the Session Manager sessions.

Stopping PASOE AppServer  
Methods to stop/restart an OpenEdge 12.2.x PASOE instance
Notes
Keyword Phrase
Last Modified Date10/25/2023 1:34 PM

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