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PASOE Session Manager HTTP sessions are not properly terminated via OEM

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TitlePASOE Session Manager HTTP sessions are not properly terminated via OEM
URL NamePASOE-Session-Manager-HTTP-sessions-are-not-properly-terminated-via-OEM
Article Number000218785
EnvironmentProduct: OpenEdge
Version: 12.2
OS: All supported platforms
Other: PASOE, OEM
Question/Problem Description
When a Session Manager HTTP session is terminated via OE Management / Explorer and the client uses the session-free session model, then the client can still continue using this session without any issues. So the session is not properly terminated. Instead of throwing an error, the PASOE instance will create a new HTTP session with the same session ID and continues to process the requests from the client.

 
Steps to Reproduce1) Open the Client Sessions page in OE Management / Explorer (e.g. Resources / OpenEdge / Progress Application Server / oepas1 / ABL Application: oepas1 / Sessions).
2) From an ABL client that uses the session-free session model, call a procedure on the PASOE instance without disconnecting.
3) Note down the newly created session in OE Management / Explorer.
4) Select the session in OE Management / Explorer and click on the red stop button to terminate the session.
5) From the ABL client, using the same connection object, call a procedure on the PASOE instance.
6) Notice that no error is returned and the same session reappears in OE Management / Explorer.
Clarifying Information
OE Management / Explorer uses the REST API to terminate the session, but what makes the request from OEM special is the sequence of REST API calls that it performs:

1) List available sessions
2) Terminate the session
3) List available sessions

Normally a user would simply perform steps 1 and 2, but step 3 is what seems to prevent the session from being properly terminated.

If the session is properly terminated, then the following error should be returned by an ABL client:
 
Failure reading response from Application Server. (14810)

From a .NET Open Client the following error is returned:
 
Communication layer message: General Error: 9998. (7175)

The PASOE Session Manager log file (e.g. oepas1.<date>.log) will show the following error:
 
An error occurred processing the POST request :  Unexpected error : com.progress.appserv.broker.exception.BrokerException$InvalidSessionStateException: Session. (18320)
Error Message
Defect NumberOCTA-47711
Enhancement Number
Cause
The exact cause is not known at this time.
 
Resolution
Until the fix is available, use the workaround below.
 
Workaround
Follow these steps:
  • Determine the Session Manager (HTTP) session ID for this request. For example:
  • Use the REST API to terminate the session that was just created (see https://docs.progress.com/bundle/pas-for-openedge-reference-122/page/Terminate-a-session.html ).
Notes
Keyword Phrase
Last Modified Date7/15/2022 11:51 AM

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