Salesforce

Errors 450 and 3191 for TABLE 0 from terminal service connection to database

« Go Back

Information

 
TitleErrors 450 and 3191 for TABLE 0 from terminal service connection to database
URL NameP51804
Article Number000141957
EnvironmentWindows
Progress/OpenEdge Product Family
Question/Problem Description
Errors 450 and 3191 for TABLE 0 from terminal service connection to database
No record listed in the error 450
SYSTEM ERROR: Cannot read field 24 from record , not enough fields. (450)
SYSTEM ERROR: Failed to extract field 24 from <file-name> record (table 0) with recid -2. (3191)
Clients connecting through a terminal server
Error 3191 reported by the remote server: SRV
Remote client generating the 3191 and 450 error messages
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
We would only suspect possible db corruption if: error 3191 is reported by
a)  SVR   tablename provided
b)  USR  tablename provided
c)  USR  table 0

only client memory corrupt if:
SVR table 0

Table 0 is a pseudo-table where 4GL variables are stored. Therefore error 3191 with table 0 does not indicate database corruption, but rather that the memory is corrupt on the remote client.

In this case it was because certain privaleges on user accounts only allow one login. When the second TS session is opened through the same terminal server, the first TS session that was connected to the database is terminated aggressively and as a result the shared memory on the client is in an inconsistent state.
Resolution
Review the permissions on the user generating these instances or review their need for more than one session.
Workaround
Notes
Keyword Phrase
Last Modified Date9/13/2015 2:26 PM

Powered by