Salesforce

Clients cannot connect to source database in a replicated configuration

« Go Back

Information

 
TitleClients cannot connect to source database in a replicated configuration
URL NameP175587
Article Number000161311
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: All supported platforms
Question/Problem Description
Self service connections to the source database fail or hang
Replication Server (RPLS) process is still running after the target has gone down

Executing "dsrutil -C monitor" fails
Cannot connect to replication shared memory.  Status = -1

Target database crashed due to power failure
Target database had been down for a considerable time
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
The ​the pica buffer queue to filled up causing the source database to hang.

The Source database configured timeouts lead to the RPLS-Q buffer filling while the RPLS was running, waiting to connect to a target database that could not be connected to as it was down.

[server]
Repl-Keep-Alive was set to 86400 seconds (24 hours)

and

[control.agent]
connect-time was set to 3600 (1 hour),

  
Resolution
Reconsider the source database's Repl-Keep-Alive and connect-time out values.

Set these to timeout values where by the Replication Server will shut down when communication to the target database is not resumed in a reasonable time
Workaround
Notes
Keyword Phrase
Last Modified Date11/7/2017 12:12 PM

Powered by