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Cannot see changes to WebSpeed application unless WebSpeed broker is restarted

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Information

 
TitleCannot see changes to WebSpeed application unless WebSpeed broker is restarted
URL NameP173291
Article Number000137825
EnvironmentAll Supported Operating Systems
Progress 9.x
OpenEdge 10.x
Question/Problem Description
Cannot see changes to WebSpeed application unless WebSpeed broker is restarted
Old procedures still run even after they have been replaced with updated code in the WebSpeed broker's working directory
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
WebSpeed agent startup parameters included -q (Quick Request). Therefore the agent ran the code that was already in memory, rather than checking for updated code in the working directory.
Resolution
Do not use the -q parameter when starting WebSpeed agents if code is expected to be changing, as is typical in a development environment. Using -q is appropriate for a stable production environment, where it can speed up execution times.
Workaround
Notes

References to Written Documentation:

OpenEdge Deployment: Startup Command and Parameter Reference, "Startup Parameter Descriptions > Quick Request (-q)"

Keyword Phrase
Last Modified Date9/13/2015 12:25 PM

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