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UBROKER log files larger than logthreshold size

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TitleUBROKER log files larger than logthreshold size
URL NameP132137
Article Number000160076
EnvironmentProduct: Progress OpenEdge
Version: All supported versions
OS: All supported platforms
Question/Problem Description
UBROKER log files larger than -logthreshold value set
log file threshold size range is valid between 500,000 and 2,147,483,647
srvrLogThreshold and srvrNumLogFiles are set
brkrLogThreshold and brkrNumLogFiles are set
Steps to Reproduce
Clarifying Information
Resulting log files are correctly named in sequence:
asbroker1.server.000001.log
asbroker1.server.000002.log
asbroker1.server.000003.log
Error Message
Defect Number
Enhancement Number
Cause
The append option is set against the related ubroker logging:

In the OE Console:
Append to broker log file = true
Append to agent log file = true

In the ubroker.properties:
brkrLogAppend=1
srvrLogAppend=1

If the append option has not been configured specifically for the Ubroker, it may be set at a higher level where it is inherited. For example:

[UBroker]
>> [UBroker.AS]
>> >> [UBroker.AS.asbroker1]
>> [UBroker.WS]
>> >> [UBroker.WS.wsbroker1]
Resolution
To reset the UBroker log files:

At the next opportunity when the ubroker in question is stopped:
  1. Archive current ubroker log files and delete all of them for this ubroker, so that the logfile directory is empty
  2. Consider increasing the number of log files (brkrNumLogFiles, srvrNumLogFiles) or disabling the append toggle (brkrLogAppend, srvrLogAppend) and perhaps increasing the threshold size (brkrLogThreshold, srvrLogThreshold).
  3. Ubroker log files quickly reach threshold size when logging entry types (brkrLogEntryTypes, srvrLogEntryTypes) and higher logging levels (brkrLoggingLevel, srvrLoggingLevel) are specified.
    eg: UBroker.All,DB.Connects,4GLTrace:4,FileID,QryInfo
  4. If the logfile directory is not local to the ubroker (eg: a mapped drive across the network) Network latency may also be affecting the content of each ubroker log file.
  5. Consider tuning the srvrLogWatchDogInterval property (default 60 seconds)
In addition, the srvrLogThreshold specifically can also grow beyond it's configured size. This is because Ubroker Agents must be informed that the log file is switched; if they are busy at the time we do not interrupt them.  The next time they are available they will get the message to use to a different log file from the Broker and then they will start writing to the new server log.  It is expected that the server log size may vary somewhat due to this. For further discussion, refer to Article:
Workaround
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:00 AM

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