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Unable to run IDXACTIVATE online if remote server process present

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Information

 
TitleUnable to run IDXACTIVATE online if remote server process present
URL NameP128640
Article Number000131122
EnvironmentProduct: OpenEdge
Version: 10.0x, 10.1A, 10.1B
OS: All supported platforms
Other: IDXACTIVATE
Question/Problem Description
Unable to run IDXACTIVATE online when ABL remote servers are present.

Connections with timestamps older than  <dbtimestamp> exist. (13246)
Do you wish to continue waiting..... Type y to continue (y/n). (13247)


The Connections referred are Remote server processes are currently connected to the database.
No remote ABL clients are currently connected to the database.
 
Steps to Reproduce
Clarifying Information
SQL remote servers do not prevent IDXACTIVATE from running.
Error Message
Defect NumberDefect PSC00188943 / OE00154022
Enhancement Number
Cause
IDXACTIVATE online will not run while a remote server process is connected to the database, even if there are no active remote ABL clients.
Resolution
Upgrade to OpenEdge 10.1C or later, where remote ABL Servers are not considered in the active timestamp check. 

While the IDXACTIVATE feature was introduced in OpenEdge 10.1A, OpenEdge 10.2B08, 11.2.1, 11.3.0 or later are recommended. Previously there were issues where interrupting an IDXACTIVATE during the key build phase, leaves the index as active (but it's not built) and another that left admin locks behind when interrupted. Otherwise please refer to the Articles referenced below for additional considerations.
Workaround
If all remote ABL users are disconnected and no exclusive locks or latches are held, terminate the remote server process through PROMON to the IDXACTIVATE session to continue:

$   promon R&D -> 4. Administrative Options -> 7. Terminate Server

For further information please refer to Article: P39432, How to terminate a remote server process?   
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:29 AM

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