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PURG locks remain in database over time for AppServer agent connections

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Information

 
TitlePURG locks remain in database over time for AppServer agent connections
URL NameP126935
Article Number000147642
EnvironmentAll Supported Operating Systems
OpenEdge 10.1A
OpenEdge 10.1B
Question/Problem Description
PURG locks remain in database over time for AppServer agent connections
Lock table is growing over time
Promon shows an increasing number of locks in the PURG chain
Locks carry the NOLK flag
Locks disappear only when the AppServer agents are shut down or restarted
Locks stay when user sessions disconnect from running AppServer agent
Steps to Reproduce
Clarifying Information
Error Message
Defect NumberOE00160855
Enhancement Number
Cause
As described in solution P124618 , PURG locks are a normal feature of the product starting on OpenEdge 10.1A. However, in the case of the AppServer the logic in charge of automatically removing the PURG locks when the agent finishes handling a specific client session is not functional.
Resolution
Upgrade to OpenEdge 10.1C or later.
Workaround
Notes
Keyword Phrase
Last Modified Date9/13/2015 3:45 PM

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