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Openedge management (OEM) and oejmx show different status for the same 4GL session

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TitleOpenedge management (OEM) and oejmx show different status for the same 4GL session
URL NameOpenedge-management-OEM-and-oejmx-show-different-status-for-the-same-4GL-session
Article Number000119420
EnvironmentProduct: OpenEdge
Version: 11.7.3, 11.7.5
OS: HP UX
Other: oejmx, OEManager
Question/Problem Description
Openedge management (OEM) and oejmx show different status for the same 4GL session
Steps to ReproduceBelow are the steps to purposely orchestrate this issue:
1. Reduced the execution to only 3.
And tied up all 3 sessions.
oejmx output: {"activeCount":3} {"queueSize":52}

2. OEM report the ablsession as idle. And stack page is empty.
oejmx shows the correct status as active.
Clarifying Information
Default Tomcat execution pool size is 300.
 
Error Message
Defect NumberDefect ADAS-22621
Enhancement Number
Cause
OEM is using oemanager api to get all the information of the PASOE instances.
The request will go through Tomcat execution pool as well as other services deployed under this instance.
If execution pool is exhausted and all the execution threads are tied up, this could cause the inconsistency between oemanager and oejmx.
Resolution
Use oejmx instead.
Oemanager and oejmx are calling the same the same java bean to get the information. 
The difference is oejmx does not go through Tomcat execution pool.

or 

Use the workaround below.

 
Workaround
Notes
References to Other Documentation:
Progress Article(s):
PASOE Sessions get stuck in Request State "Reading"
Keyword Phrase
Last Modified Date12/7/2020 10:39 PM

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